Bug 1462066 - Dict_t leak in dht_migration_complete_check_task and dht_rebalance_inprogress_task
Dict_t leak in dht_migration_complete_check_task and dht_rebalance_inprogres...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Nithya Balachandran
Karan Sandha
:
: 1462537 (view as bug list)
Depends On: 1409186 1462537
Blocks: 1410369 1417151
  Show dependency treegraph
 
Reported: 2017-06-16 01:08 EDT by Atin Mukherjee
Modified: 2017-09-21 00:59 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1409186
Environment:
Last Closed: 2017-09-21 00:59:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2017-06-16 01:08:50 EDT
+++ This bug was initially created as a clone of Bug #1409186 +++

Description of problem:
Code reading reveals a dictionary leak in both the dht_migration_complete_check_task and  dht_rebalance_inprogress_task functions.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2016-12-30 00:07:15 EST ---

REVIEW: http://review.gluster.org/16308 (cluster/dht: Fix dict_leak in migration check tasks) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)

--- Additional comment from Worker Ant on 2017-01-02 10:30:14 EST ---

COMMIT: http://review.gluster.org/16308 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 11b6a2c9fc5232b58774cab29873406c0fbfef19
Author: N Balachandran <nbalacha@redhat.com>
Date:   Fri Dec 30 10:33:13 2016 +0530

    cluster/dht: Fix dict_leak in migration check tasks
    
    Fixed a memleak where dict was not being unrefed
    in the dht_migration_complete_check_task and
    dht_rebalance_inprogress_task functions.
    
    Change-Id: I3d42e9a2e5c8596c985bf6431a68fd3905227383
    BUG: 1409186
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/16308
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

--- Additional comment from Shyamsundar on 2017-03-06 12:41:22 EST ---

This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/
Comment 4 Atin Mukherjee 2017-06-19 00:25:28 EDT
*** Bug 1462537 has been marked as a duplicate of this bug. ***
Comment 10 Alok 2017-07-11 02:16:00 EDT
Approving the accelerated fix request. Fix to be included in the next downstream version to avoid regression.
Comment 22 Prasad Desala 2017-08-04 06:15:29 EDT
Nithya,
Could you please provide me the steps to reproduce this mem leak issue.
Comment 26 errata-xmlrpc 2017-09-21 00:59:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.