Bug 1414508 - refresh of OCP 3.2 crashes with permission error in recovery
Summary: refresh of OCP 3.2 crashes with permission error in recovery
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.8.0
Assignee: zakiva
QA Contact: Einat Pacifici
URL:
Whiteboard: container:ems_refresh
: 1410374 1415843 (view as bug list)
Depends On:
Blocks: 1417974
TreeView+ depends on / blocked
 
Reported: 2017-01-18 17:04 UTC by Felix Dewaleyne
Modified: 2020-03-11 15:37 UTC (History)
15 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1417974 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:45:30 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description Felix Dewaleyne 2017-01-18 17:04:20 UTC
Description of problem:
refresh of OCP 3.2 crashes with permission error

Version-Release number of selected component (if applicable):
cfme-5.7.0.17-1

How reproducible:
all the time - customer env

Steps to Reproduce:
1. refresh the OCP provide
2.
3.

Actual resultss:
[----] I, [2017-01-18T15:19:12.125449 #2830:91314c]  INFO -- : MIQ(MiqQueue.put_or_update) Message id: [1401000001534640] updated with following: {:queue_name=>"ems_1401000000000004", :state=>"ready", :zone=>"default", :class_name=>"EmsRe
fresh", :method_name=>"refresh", :role=>"ems_inventory", :args=>[[["ManageIQ::Providers::OpenshiftEnterprise::ContainerManager", 1401000000000004]]], :msg_timeout=>7200, :task_id=>nil}
[----] I, [2017-01-18T15:19:12.125751 #2830:91314c]  INFO -- : MIQ(MiqQueue.put_or_update) Message id: [1401000001534640],  id: [], Zone: [default], Role: [ems_inventory], Server: [], Ident: [ems_1401000000000004], Target id: [], Instance
 id: [], Task id: [], Command: [EmsRefresh.refresh], Timeout: [7200], Priority: [100], State: [ready], Deliver On: [], Data: [], Args: [[["ManageIQ::Providers::OpenshiftEnterprise::ContainerManager", 1401000000000004]]], Requeued
[----] I, [2017-01-18T15:19:12.125986 #2830:91314c]  INFO -- : <AutomationEngine> Followed  Relationship [miqaedb:/System/event_handlers/event_action_refresh?target=ems#create]
[----] I, [2017-01-18T15:19:12.126294 #2830:91314c]  INFO -- : <AutomationEngine> Followed  Relationship [miqaedb:/System/Event/EmsEvent/KUBERNETES/CONTAINER_UNHEALTHY#create]
[----] I, [2017-01-18T15:19:12.126894 #2830:91314c]  INFO -- : MIQ(MiqQueue#delivered) Message id: [1401000001534645], State: [ok], Delivered in [0.151325699] seconds
[...]
[----] E, [2017-01-18T15:19:12.320568 #2930:91314c] ERROR -- : MIQ(ManageIQ::Providers::OpenshiftEnterprise::ContainerManager::Refresher#refresh) EMS: [CBP], id: [1401000000000004] Refresh failed
[----] E, [2017-01-18T15:19:12.323573 #2930:91314c] ERROR -- : [NoMethodError]: undefined method `each_with_object' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2017-01-18T15:19:12.323769 #2930:91314c] ERROR -- : /var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:168:in `parse_env_variables'
/var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:198:in `parse_openshift_image'
/var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:17:in `block in get_openshift_images'
/var/www/miq/vmdb/app/models/manageiq/providers/kubernetes/container_manager/refresh_parser.rb:136:in `process_collection_item'
/var/www/miq/vmdb/app/models/manageiq/providers/kubernetes/container_manager/refresh_parser.rb:130:in `block in process_collection'
/opt/rh/rh-ruby23/root/usr/share/ruby/delegate.rb:341:in `each'
[...]

Expected results:
no error in rescue

Additional info:
probable regression of bz#1282815
testing with cfme-5.7.0.1-2 in progress

Comment 2 Federico Simoncelli 2017-01-23 10:52:22 UTC
I am almost certain this is a duplicate of bug 1405937

Please confirm and we'll close it.

Comment 3 Felix Dewaleyne 2017-01-23 13:45:51 UTC
(In reply to Federico Simoncelli from comment #2)
> I am almost certain this is a duplicate of bug 1405937
> 
> Please confirm and we'll close it.

unlikely to be the same issue. applying the rpm did not solve the issue. working on the logs and updating this further.

Comment 5 Federico Simoncelli 2017-01-23 14:17:04 UTC
(In reply to Felix Dewaleyne from comment #3)
> (In reply to Federico Simoncelli from comment #2)
> > I am almost certain this is a duplicate of bug 1405937
> > 
> > Please confirm and we'll close it.
> 
> unlikely to be the same issue. applying the rpm did not solve the issue.
> working on the logs and updating this further.

Thanks, so the traceback in the description is no more relevant (it was indeed the one about images). I now see this one:

[----] E, [2017-01-19T09:19:01.710063 #5587:e51140] ERROR -- : MIQ(ManageIQ::Providers::OpenshiftEnterprise::ContainerManager::Refresher#refresh) EMS: [CBP], id: [1401000000000004] Refresh failed
[----] E, [2017-01-19T09:19:01.713503 #5587:e51140] ERROR -- : [NoMethodError]: undefined method `each_with_object' for nil:NilClass  Method:[rescue in block in refresh]
[----] E, [2017-01-19T09:19:01.713691 #5587:e51140] ERROR -- : /var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:168:in `parse_env_variables'
/var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:198:in `parse_openshift_image'
/var/www/miq/vmdb/app/models/manageiq/providers/openshift/container_manager/refresh_parser.rb:17:in `block in get_openshift_images'
/var/www/miq/vmdb/app/models/manageiq/providers/kubernetes/container_manager/refresh_parser.rb:136:in `process_collection_item'
/var/www/miq/vmdb/app/models/manageiq/providers/kubernetes/container_manager/refresh_parser.rb:130:in `block in process_collection'

Zahi please note that there are more details in the VM log.

Comment 6 Federico Simoncelli 2017-01-23 16:16:39 UTC
*** Bug 1410374 has been marked as a duplicate of this bug. ***

Comment 8 Federico Simoncelli 2017-01-23 17:33:20 UTC
https://github.com/ManageIQ/manageiq/pull/13624

Comment 9 Jared Deubel 2017-01-24 02:04:30 UTC
*** Bug 1415843 has been marked as a duplicate of this bug. ***

Comment 10 Felix Dewaleyne 2017-01-24 10:18:15 UTC
customer : Applied https://github.com/ManageIQ/manageiq/pull/13624 - provider refresh is now successful.

however as it looks more work is being done, they would prefer to get a rpm once all work is finished .

Comment 23 Einat Pacifici 2017-04-24 08:35:16 UTC
Verified.


Note You need to log in before you can comment on or make changes to this bug.