Bug 14105 - gtop 'just crashes' (sorry!) after about ten seconds
Summary: gtop 'just crashes' (sorry!) after about ten seconds
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtop   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard: Winston rc1
Keywords:
: 13833 14981 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-17 09:13 UTC by Telsa Gwynne
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-01 21:14:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Telsa Gwynne 2000-07-17 09:13:05 UTC
Start gtop. After about ten seconds or so, it simply
'goes away'. Starting from a terminal gets some error
messages: I have snipped the first twenty or so lines
of "Gtk-WARNING **: Unable to locate loadable module in module_path:
"libpixmap.so","

Gtk-WARNING **: Unable to locate loadable module in module_path:
"libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path:
"libpixmap.so",
Gtk-WARNING **: Unable to locate loadable module in module_path:
"libpixmap.so",
GnomeUI-WARNING **: Could not open help topics file NULL
glibtop: glibtop_get_proc_state (): Client requested field mask 0000f, but
only have 0000c.
glibtop: open (/proc/stat): Too many open files

Wasn't sure whether this is gtop's fault or libgtop's. 
Also, I say 'after about ten seconds'. What usually
happens is that I get bored waiting, start to move the
mouse to place a window over/beneath it because that's
what was happening the first crash, and it crashes before
I can move the window. Dunno whether it's related. I doubt
it: I'm just being completist.

Comment 1 Matt Domsch 2000-07-28 18:12:29 UTC
I've seen this happen in Pinstripe now also.
Also, the process names often have garbage characters in them, especially at the
end of the name.

Comment 2 Elliot Lee 2000-07-28 18:18:05 UTC
I've verified this bug separately - was waiting for the author to reply, I
suppose I will have to start making a more serious effort.

Comment 3 Glen Foster 2000-07-30 23:04:18 UTC
This defect is considered MUST-FIX for Winston Release-Candidate #1

Comment 4 Chris Evans 2000-07-31 22:49:37 UTC
I was just about to log this :-)
I see copious garbage characters and the 10 second or so crash

Comment 5 Pekka Pietikäinen 2000-08-01 14:08:31 UTC
WORKSFORME (tm) after upgrading to libgtop-1.0.7. 1.0.6 apparently forgets to
close the files
in /proc it opens.

Comment 6 Elliot Lee 2000-08-01 21:14:27 UTC
*** Bug 14981 has been marked as a duplicate of this bug. ***

Comment 7 Elliot Lee 2000-08-01 21:28:42 UTC
Fixed in libgtop-1.0.9-1

Comment 8 Tim Waugh 2000-08-02 12:39:24 UTC
*** Bug 13833 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.