Bug 1414022 - [RFE] [Octavia] Supplying the overcloud with base Amphora image after deployment
Summary: [RFE] [Octavia] Supplying the overcloud with base Amphora image after deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
: 1432480 (view as bug list)
Depends On: 1434826 1477480
Blocks: 1442136 1433523 1433537 1552443
TreeView+ depends on / blocked
 
Reported: 2017-01-17 14:44 UTC by Alexander Stafeyev
Modified: 2019-09-10 14:10 UTC (History)
20 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-16.el7ost openstack-tripleo-heat-templates-8.0.2-15.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gerrithub.io 412362 0 None None None 2018-05-24 11:19:20 UTC
OpenStack gerrit 562019 0 None master: MERGED tripleo-common: Octavia amphora image handles updates and symlinks (I48ad8971e34ddebd50f5eb36e22a3d072e011d14) 2018-05-24 12:59:21 UTC
OpenStack gerrit 562086 0 None master: MERGED tripleo-heat-templates: Octavia amphora image handling updates (Ib5338d0fadc9c1c8fcf73c53e4364d35a5f29fe7) 2018-05-24 12:59:16 UTC
OpenStack gerrit 566556 0 None stable/queens: NEW tripleo-common: Octavia amphora image handles updates and symlinks (I48ad8971e34ddebd50f5eb36e22a3d072e011d14) 2018-05-24 12:59:10 UTC
OpenStack gerrit 566557 0 None stable/queens: NEW tripleo-heat-templates: Octavia amphora image handling updates (Ib5338d0fadc9c1c8fcf73c53e4364d35a5f29fe7) 2018-05-24 12:59:04 UTC
OpenStack gerrit 566913 0 None master: MERGED tripleo-common: Install Octavia amphora image if Red Hat (I3ed8144b52ba528f449a4abe5c2106a5c61f9d61) 2018-05-24 12:58:58 UTC
OpenStack gerrit 568801 0 None stable/queens: NEW tripleo-common: Install Octavia amphora image if Red Hat (I3ed8144b52ba528f449a4abe5c2106a5c61f9d61) 2018-05-24 12:58:53 UTC
OpenStack gerrit 570163 0 None master: NEW tripleo-common: Fix Octavia amphora image RPM install (I84b0d4f18f1c382201dd5cf782152c5e973da513) 2018-05-24 12:58:48 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:31:13 UTC

Description Alexander Stafeyev 2017-01-17 14:44:43 UTC
Description of problem:
When we deploy Openstack  cloud with LBaaS (octavia), We would like to have basic Amphora image ready. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Lon Hohberger 2017-01-17 15:01:57 UTC
Please clarify the requirements. What packages need to be present in this image?

Comment 3 Brent Eagles 2017-01-17 15:04:52 UTC
Upstream blueprint https://blueprints.launchpad.net/tripleo/+spec/octavia-amphorae-in-overcloud

This work is currently planned for the Pike cycle.

Comment 5 Assaf Muller 2017-01-18 19:11:38 UTC
@Ofer this was never planned or targeted for 11, moving to 12. We have tons of other work we need to do to enable Octavia on a very basic level before we can worry about a better user experience by supplying an image.

Comment 6 Alexander Stafeyev 2017-02-05 20:39:30 UTC
We just need to execute an image build like in the following doc : 

https://docs.google.com/document/d/1FIoSOp7fNoKokf-xHjKsxeJq3A6YTi1j-6W3F_cvT1Y/edit#heading=h.snmyvps3ybia

Comment 8 Brent Eagles 2017-04-13 18:12:46 UTC
*** Bug 1432480 has been marked as a duplicate of this bug. ***

Comment 18 Carlos Goncalves 2018-03-21 13:36:31 UTC
Workaround on Infrared side to upload image to Glance on overcloud deployment phase: https://review.gerrithub.io/#/c/403834/

Thanks to Brent and Or, Triple-O can today upload the image to Glance if the image file exists where Triple-O expects it to be (OctaviaAmphoraImageFilename) [1].

On OSP deployments, the amphora image file path differs from what's set upstream, i.e. the image is located in /usr/share/rhosp-director-images/. In conversations within the Octavia squad, we agreed it would be nice to have distro-specific environment files that would override the default image path.

Moving back to ASSIGNED.

[1] https://github.com/openstack/tripleo-heat-templates/blob/stable/queens/docker/services/octavia/octavia-deployment-config.yaml#L42-L45

Comment 19 Carlos Goncalves 2018-03-28 07:57:04 UTC
The additional steps in comment #18 do not block this RFE. Rather, they should be tracked in a separate rhbz.

Comment 43 Nir Magnezi 2018-05-24 11:19:20 UTC
To avoid future confusion, I proposed this[1] patch so infrared will not handle the amphora image instead of TripleO

[1] https://review.gerrithub.io/c/redhat-openstack/infrared/+/412362

Comment 49 errata-xmlrpc 2018-06-27 13:29:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.