Bug 1433537 - [RFE][Octavia] Containerized deployment of Octavia services
Summary: [RFE][Octavia] Containerized deployment of Octavia services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
: 1488801 (view as bug list)
Depends On: 1414022 1462670 1506641 1506644 1566463
Blocks: 1442136 1174691 1415556 1433523 1449938 1454762 1469348 1488797 1504642 1552443
TreeView+ depends on / blocked
 
Reported: 2017-03-17 23:56 UTC by Assaf Muller
Modified: 2019-09-10 14:10 UTC (History)
16 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:29:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 467239 None master: MERGED tripleo-common: Add octavia container images (I3a169e3321a26ee373ab873426a2d58acbcfe1bd) 2018-02-28 13:27:43 UTC
OpenStack gerrit 467254 None master: MERGED tripleo-heat-templates: Add docker templates for octavia services (I211707072bb0e4ac4aa48e9bbaccb7530f3de0ca) 2018-02-28 13:27:36 UTC
OpenStack gerrit 536816 None master: MERGED tripleo-heat-templates: Ensure packages for octavia only when EnablePackageInstall is True (I1374b20ec66694fe661183e089f... 2018-02-28 13:27:28 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:31:00 UTC

Description Assaf Muller 2017-03-17 23:56:30 UTC
Provide containerized deployment of Octavia services using docker-cmd based framework (phase 1).

Comment 2 Assaf Muller 2017-07-05 22:23:38 UTC
All patches merged upstream. Some additional testing required, but the functionality has been merged.

Comment 7 Nir Magnezi 2017-11-14 12:09:00 UTC
Should be ready for QE verification as soon as we finish the "Depends on" bugs: bug 1462670 and bug 1506641

Comment 17 Jakub Libosvar 2017-12-14 14:36:58 UTC
*** Bug 1488801 has been marked as a duplicate of this bug. ***

Comment 18 Jakub Libosvar 2017-12-14 16:17:26 UTC
I'm moving this back to POST as all containerization specific patches are merged and bug 1462670 is related to deployment.

Comment 30 errata-xmlrpc 2018-06-27 13:29:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.