Bug 1416546 - mongodb fills with event type of "objectstore.http.request" with gnocchi driver=swift
Summary: mongodb fills with event type of "objectstore.http.request" with gnocchi driv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ceilometermiddleware
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1449986 (view as bug list)
Depends On:
Blocks: 1468223 1468225
TreeView+ depends on / blocked
 
Reported: 2017-01-25 19:10 UTC by Dave Wilson
Modified: 2020-06-11 13:14 UTC (History)
13 users (show)

Fixed In Version: python-ceilometermiddleware-1.0.1-0.20170228134010.6ba005f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1468223 1468225 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 464189 0 None MERGED Add support for ignore_projects for ceilometer events 2020-05-29 18:11:15 UTC
OpenStack gerrit 464559 0 None MERGED retrieve project id to ignore from keystone 2020-05-29 18:11:15 UTC
OpenStack gerrit 467269 0 None MERGED Add ignore_projects to filter gnocchi events 2020-05-29 18:11:15 UTC
Red Hat Knowledge Base (Solution) 3032371 0 None None None 2017-05-22 14:57:23 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Dave Wilson 2017-01-25 19:10:44 UTC
Description of problem: 
mongodb fills disk with event data of "objectstore.http.request" with gnocchi driver=swift


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Create overcloud (non ceph) 
2. Deploy a few vms

Actual results: 
mongodb fills with many "objectstore.http.request" filling up system disk


Expected results:


Additional info: 
Below is a breakdown of document count by event type in collection after a few days of running in overcloud with 4 compute nodes and 10 VMs

DB size : ceilometer event colletion size  12GB

Event Document Count
----------------------------------
"objectstore.http.request", 3505417
"identity.authenticate", 34043
"compute.instance.exists", 446
"compute.instance.update", 70
"identity.endpoint.created", 39
"identity.role_assignment.created", 15
"identity.service.created", 13
"identity.user.created", 12
"scheduler.select_destinations.start", 10
"scheduler.select_destinations.end", 10
"port.update.start", 10
"port.update.end", 10
"port.create.start", 10
"port.create.end", 10
"compute.instance.create.start", 10
"compute.instance.create.end", 10
"identity.role.created", 5
"image.send", 4
"identity.user.updated", 3
"image.update", 2
"identity.project.created", 2
"identity.domain.created", 2
"subnet.create.start", 1
"subnet.create.end", 1
"network.create.start", 1
"network.create.end", 1
"image.upload", 1
"image.prepare", 1
"image.create", 1
"image.activate", 1
"identity.region.created", 1
"identity.project.updated", 1

Comment 1 Julien Danjou 2017-03-13 15:37:23 UTC
Hi Dave,


Those objects are meant to be filtered by Ceilometer if they are generated by Gnocchi itself. Is it the case? You should have filter_service_activity=True in ceilometer.conf under the gnocchi dispatcher section.

How and why did you deploy both Gnocchi and MongoDB?

Comment 3 Julien Danjou 2017-03-14 09:39:36 UTC
Hi David,

Ok, I did not get it was event related. So the filtering only happens in the metric part anyway.

In this case, what should be checked if whetever "ignore_projects" is set in /etc/swift/proxy-server.conf. That should be set to the project id that gnocchi is using. Its default value is "gnocchi", so if the project gnocchi is using to access Swift is "gnocchi" that would also work.

Comment 6 Dave Wilson 2017-04-06 03:20:26 UTC
It's not set

[root@overcloud-controller-0 ~]# grep ignore /etc/swift/proxy-server.conf
[root@overcloud-controller-0 ~]#

Comment 10 Thierry Vignaud 2017-06-27 13:03:04 UTC
The relevant changes are in python-ceilometermiddleware-1.0.1-0.20170228134010.6ba005f.el7ost, openstack-tripleo-heat-templates-7.0.0-0.20170624014919.el7ost & puppet-swift-11.2.0-0.20170623014910.e8f765d.el7ost

Comment 13 Julien Danjou 2017-08-11 13:25:44 UTC
*** Bug 1449986 has been marked as a duplicate of this bug. ***

Comment 17 errata-xmlrpc 2017-12-13 21:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.