Bug 1468225 - mongodb fills with event type of "objectstore.http.request" with gnocchi driver=swift
mongodb fills with event type of "objectstore.http.request" with gnocchi driv...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ceilometermiddleware (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
urgent Severity urgent
: z4
: 10.0 (Newton)
Assigned To: RHOS Maint
Sasha Smolyak
: Triaged, ZStream
Depends On: 1416546
Blocks: 1468223
  Show dependency treegraph
 
Reported: 2017-07-06 07:44 EDT by Pradeep Kilambi
Modified: 2017-09-06 13:06 EDT (History)
19 users (show)

See Also:
Fixed In Version: python-ceilometermiddleware-0.5.1-3.el7ost, puppet-swift-9.5.0-2.el7ost, openstack-tripleo-heat-templates-5.2.0-23.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1416546
Environment:
Last Closed: 2017-09-06 13:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3032371 None None None 2017-07-06 07:44 EDT
OpenStack gerrit 464189 None None None 2017-07-06 07:44 EDT
OpenStack gerrit 464559 None None None 2017-07-06 07:44 EDT
OpenStack gerrit 467269 None None None 2017-07-06 07:44 EDT
OpenStack gerrit 486684 None None None 2017-08-02 13:43 EDT

  None (edit)
Comment 7 Sadique Puthen 2017-07-24 09:47:42 EDT
Julien,

Is this https://review.openstack.org/#/c/478953/ also part of the backport for OSP-10? If no, can we include it as part of this bz?

Disable swift middleware ceilometer pipeline by default

This generates tons of unnecessary events when gnocchi uses swift backend.
We end up filtering most of these anyway. So lets disable this so it
doesn't put useless load. Also changing the default project to service as
thats what gnocchi uses to authenticate with swift.
Comment 12 Sasha Smolyak 2017-08-20 01:53:59 EDT
No events from swift, no resource in gnocchi resource list
Comment 14 errata-xmlrpc 2017-09-06 13:06:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2653

Note You need to log in before you can comment on or make changes to this bug.