Bug 1416689 - Fix spurious failure of ec-background-heal.t
Summary: Fix spurious failure of ec-background-heal.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard: test-failure
: 1419443 (view as bug list)
Depends On:
Blocks: 1419696 1422838
TreeView+ depends on / blocked
 
Reported: 2017-01-26 09:19 UTC by Xavi Hernandez
Modified: 2017-05-30 18:39 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1422838 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:39:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2017-01-26 09:19:08 UTC
Description of problem:

basic/ec/ec-background-heal.t fails spuriously.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-01-26 09:25:16 UTC
REVIEW: https://review.gluster.org/16470 (cluster/ec: mark ec-background-heal.t as bad) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Worker Ant 2017-01-26 12:58:22 UTC
COMMIT: https://review.gluster.org/16470 committed in master by Xavier Hernandez (xhernandez@datalab.es) 
------
commit 9e2d7faf598078d12a47512abae6792adbe01aca
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Thu Jan 26 10:24:32 2017 +0100

    cluster/ec: mark ec-background-heal.t as bad
    
    Change-Id: I0c54c62cdeb40b983da2392296762471a5474652
    BUG: 1416689
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: https://review.gluster.org/16470
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Nigel Babu 2017-02-06 08:05:50 UTC
*** Bug 1419443 has been marked as a duplicate of this bug. ***

Comment 4 Shyamsundar 2017-02-06 19:03:25 UTC
Although this bug is tracked against mainline, I backported the commit to mark this test as bad in release-3.10 as well. This is to ensure we do not get spurious failures against commits for that branch.

The Bug used to make this change is #1419696

Request any fix to be back ported and the test unblocked as appropriate.

Comment 5 Shyamsundar 2017-05-30 18:39:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.