Bug 1417708 - ovirt-ha-agent should reuse json-rpc connections
Summary: ovirt-ha-agent should reuse json-rpc connections
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha
Version: 3.6.7
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Simone Tiraboschi
QA Contact: Artyom
URL:
Whiteboard:
: 1349829 1383108 1417709 (view as bug list)
Depends On: 1343005 1349829 1376843
Blocks: 1383108 1417709 1457471 1471617
TreeView+ depends on / blocked
 
Reported: 2017-01-30 17:43 UTC by Troy Dash
Modified: 2021-03-11 15:36 UTC (History)
29 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously the ovirt-ha-agent would open a new json-rpc connection each time it communicated with VDSM. Now it will try and reuse an open connection if available to improve performance.
Clone Of: 1349829
: 1471617 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:32:29 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1472 0 None None None 2018-05-15 17:33:55 UTC
oVirt gerrit 57942 0 'None' MERGED jsonrpc: close client 2021-01-26 05:47:11 UTC
oVirt gerrit 59106 0 'None' MERGED jsonrpc: close client 2021-01-26 05:47:12 UTC
oVirt gerrit 73757 0 'None' MERGED jsonrpc: reuse existing connection 2021-01-26 05:47:54 UTC
oVirt gerrit 76212 0 'None' ABANDONED jsonrpc: reuse existing connection 2021-01-26 05:47:55 UTC

Comment 1 Troy Dash 2017-01-30 18:02:56 UTC
*** Bug 1417709 has been marked as a duplicate of this bug. ***

Comment 2 Troy Dash 2017-01-30 18:04:46 UTC
*** Bug 1349829 has been marked as a duplicate of this bug. ***

Comment 3 Sandro Bonazzola 2017-02-07 17:19:29 UTC
*** Bug 1383108 has been marked as a duplicate of this bug. ***

Comment 7 Simone Tiraboschi 2017-11-23 14:14:12 UTC
The auto reconnect feature is just in json rpc client from 4.2; abandoning 4.1 patch and already ready on 4.2.

Comment 9 Artyom 2017-11-30 16:23:45 UTC
Verified on ovirt-hosted-engine-ha-2.2.0-1.el7ev.noarch

Comment 12 errata-xmlrpc 2018-05-15 17:32:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1472

Comment 13 Franta Kust 2019-05-16 13:04:21 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.