This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1471617 - [downstream clone - 4.1.8] ovirt-ha-agent should reuse json-rpc connections
[downstream clone - 4.1.8] ovirt-ha-agent should reuse json-rpc connections
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
3.6.7
x86_64 Linux
medium Severity medium
: ovirt-4.1.8
: ---
Assigned To: Simone Tiraboschi
Artyom
: ZStream
Depends On: 1376843 1417708
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-17 01:17 EDT by rhev-integ
Modified: 2017-10-16 06:55 EDT (History)
31 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: In the past ovirt-ha-agent was opening a new connection each time it had to communicate with vdsm while now, for performance reasons, it can try to reuse an open connection if still valid. Reason: Performance reasons. Result: ovirt-ha-agent reuses an open json-rpc connection if available
Story Points: ---
Clone Of: 1417708
Environment:
Last Closed: 2017-10-16 06:49:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57942 None None None 2017-07-17 01:18 EDT
oVirt gerrit 59106 None None None 2017-07-17 01:18 EDT
oVirt gerrit 73757 master MERGED jsonrpc: reuse existing connection 2017-07-17 01:18 EDT
oVirt gerrit 76212 v2.1.z POST jsonrpc: reuse existing connection 2017-07-17 01:18 EDT

  None (edit)
Comment 1 rhev-integ 2017-07-17 01:17:52 EDT
*** Bug 1417709 has been marked as a duplicate of this bug. ***

(Originally by Dash Dash)
Comment 3 rhev-integ 2017-07-17 01:18:02 EDT
*** Bug 1349829 has been marked as a duplicate of this bug. ***

(Originally by Dash Dash)
Comment 4 rhev-integ 2017-07-17 01:18:12 EDT
*** Bug 1383108 has been marked as a duplicate of this bug. ***

(Originally by Sandro Bonazzola)
Comment 7 Sandro Bonazzola 2017-08-08 05:37:52 EDT
Postponing to 4.1.6 since we need bug #1376843 to be fixed on vdsm side in order to close this one.

Note You need to log in before you can comment on or make changes to this bug.