Bug 1417808 - Several pages missing from chapters 9, 10, 11 and 12 of the PDF version of Satellite 6.2 Provisioning Guide
Summary: Several pages missing from chapters 9, 10, 11 and 12 of the PDF version of Sa...
Keywords:
Status: CLOSED DUPLICATE of bug 1378961
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evince
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: pre-dev-freeze
: ---
Assignee: Marek Kašík
QA Contact: Desktop QE
URL:
Whiteboard:
: 1469277 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 06:38 UTC by Gordon Keegan
Modified: 2018-04-24 10:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 10:37:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
Satellite 6.2 Provisioning Guide pdf from customer portal (713.62 KB, application/pdf)
2017-01-31 06:38 UTC, Gordon Keegan
no flags Details

Description Gordon Keegan 2017-01-31 06:38:44 UTC
Created attachment 1246091 [details]
Satellite 6.2 Provisioning Guide pdf from customer portal

Document URL: https://access.redhat.com/webassets/avalon/d/Red_Hat_Satellite-6.2-Provisioning_Guide-en-US/Red_Hat_Satellite-6.2-Provisioning_Guide-en-US.pdf

Section Number and Name: Chapters 0, 10, 11 and 12

Describe the issue: missing several pages from chapters 9, 10, 11 and 12.

Suggestions for improvement: Add missing pages.

Additional information: 
Missing approximately beginning of section 9.8 to beginning of chapter 10
Missing approximately beginning of section 10.6 to just before 11.3
Missing approximately beginning of section 11.6 to just before 12.3

Comment 1 Andrew Dahms 2017-01-31 13:39:13 UTC
Hi Gordon,

Thank you for raising this bug.

Are you using a specific browser or program to view the PDF?

I have checked in several browsers and programs on a few platforms, and don't seem to be able to reproduce the issue myself, so I am wondering if it might be specific to how it is being viewed, in which case it may be difficult for us to address.

Let me know if there is anything else that comes to mind, and I'd be happy to investigate a little further for you.

Kind regards,

Andrew

Comment 2 Gordon Keegan 2017-01-31 16:10:33 UTC
Hi Andrew, I'm using the current evince doc reader (evince-3.14.2-5.el7.x86_64) from the RHEL 7 CSB build (all rpms current).  Found out this morning that when launching from a shell instead of web browser, I get the following errors when trying to view the affected pages.  The first shows up once, then the others repeat as I scroll through the pages that don't render:

----
(evince:5885): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 35

(evince:5885): Gtk-WARNING **: drawing failure for widget `EvView': out of memory

(evince:5885): Gtk-WARNING **: drawing failure for widget `GtkScrolledWindow': out of memory

(evince:5885): Gtk-WARNING **: drawing failure for widget `GtkOverlay': out of memory

(evince:5885): Gtk-WARNING **: drawing failure for widget `GtkBox': out of memory

(evince:5885): Gtk-WARNING **: drawing failure for widget `GtkPaned': out of memory

(evince:5885): Gtk-WARNING **: drawing failure for widget `GtkBox': out of memory

(evince:5885): Gtk-WARNING **: drawing failure for widget `EvWindow': out of memory
----

I don't think it's a memory allocation issue:
$  free
              total        used        free      shared  buff/cache   available
Mem:       11832780     5554864      252420      505720     6025496     5449328
Swap:       6029308         108     6029200


What viewer and OS are you using?  I'll try that from my end.

Comment 3 Andrew Dahms 2017-02-01 02:16:46 UTC
Hi Gordon,

Thank you for your reply.

I can confirm that I am running into the same issue with Evince on RHEL 7 CSB, and some testing with Evince on other platforms and configurations is showing the same issue, whereas we are unable to reproduce it in Firefox itself and other browsers.

As such, there is not much that we can do to resolve this issue from our end, and it may be easier for the platform team to address in Evince itself.

I am changing the component over accordingly, but would be happy to help follow up with this issue as it goes along if there is anything that we can do.

Thank you once again for your input.

Kind regards,

Andrew

Comment 5 Gordon Keegan 2017-02-03 16:17:18 UTC
Additional testing note, the acroread tool renders the doc as expected.

Installing rpm:
   redhat-internal-acrobat_reader-installer-0.1-2.el7.csb.x86_64
which pulls in 
   AdobeReader_enu-9.5.5-1.i486
which has pdf reader
   $ acroread -v
   9.5.5

Evince version is
   evince-3.14.2-5.el7.x86_64

Comment 6 Caolan McNamara 2017-07-11 09:25:06 UTC
*** Bug 1469277 has been marked as a duplicate of this bug. ***

Comment 7 zosy 2018-01-19 06:50:10 UTC
this bug still in there on rhel 7.4, not just rhel 7.4 but  rhel 7.0-7.4 all of versions have this issue!

please fix it

Comment 8 Marek Kašík 2018-04-24 10:37:35 UTC
Hi,

this is a duplicate of the bug #1378961. I've proposed a fix for this to upstream, but it was not accepted yet.

Regards

*** This bug has been marked as a duplicate of bug 1378961 ***


Note You need to log in before you can comment on or make changes to this bug.