Bug 1418042 - Creating a new group does not show "hosts" and "VM and Templates"
Summary: Creating a new group does not show "hosts" and "VM and Templates"
Keywords:
Status: CLOSED DUPLICATE of bug 1421196
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Jozef Zigmund
QA Contact: Ramesh A
URL:
Whiteboard: rbac
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 16:54 UTC by Shveta
Modified: 2017-02-14 12:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-14 12:29:43 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
no data (118.02 KB, image/png)
2017-01-31 16:54 UTC, Shveta
no flags Details

Description Shveta 2017-01-31 16:54:04 UTC
Created attachment 1246367 [details]
no data

Description of problem:


Version-Release number of selected component (if applicable):
5.7.1.0.20170124142149_8a5f4d5 

How reproducible:


Steps to Reproduce:
1. Create a new group
2. Hosts and VM and Templates do not show any data
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2017-02-03 15:15:22 UTC
Ramesh, is this a regression, does it work in 5.7.0?

Comment 3 Ramesh A 2017-02-06 15:56:21 UTC
Hi Dave,

Yes this is a regression issue in 5.7.1.0.20170124142149_8a5f4d5, It was working fine in 5.7.0.  I believe this issue must be related to caching.  There were some changes made recently to Groups/Roles not to open all of the nodes in the tree on initialization.  I am thinking this is related to it. 

As per my testing,
a) Nothing gets displayed in the filter options (be it My Company Tag, Hosts & Clusters or VMs & Templates) while creating a group
b) Open any existing group and open up any filter, now try creating a new group and you will find that the entries against the opened up filter get's displayed.  For example, if we open up VM & Templates for an existing group and try to create a new group, then it displays entries in VM & Templates, while other two does not get displayed.  Same with other filter options too

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1416363#c3

Comment 4 Zita Nemeckova 2017-02-14 12:29:43 UTC

*** This bug has been marked as a duplicate of bug 1421196 ***


Note You need to log in before you can comment on or make changes to this bug.