Bug 1420604 - [Docs][SHE] Review, test, and update the procedure for restoring a self-hosted engine environment
Summary: [Docs][SHE] Review, test, and update the procedure for restoring a self-hoste...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.3
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ovirt-4.2.7-1
: ---
Assignee: Tahlia Richardson
QA Contact: Nikolai Sednev
URL:
Whiteboard: docs-accepted
: 1108334 1359572 1422144 1431635 1480027 1505798 1508535 1508540 (view as bug list)
Depends On: 1235200 1240466 1568841 1620314
Blocks: 1541529 1547768 1480027 1482710 1654935
TreeView+ depends on / blocked
 
Reported: 2017-02-09 04:17 UTC by Lucy Bopf
Modified: 2021-06-10 11:55 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 05:11:39 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1450902 0 medium CLOSED [RFE][TestOnly] ovirt-hosted-engine-setup should be able to migrate from non-hosted-engine setups 2021-05-01 16:34:11 UTC
Red Hat Bugzilla 1573880 0 unspecified CLOSED Restoring Backup on Selfhosted-Engine fails due to connected storage domain 2021-02-22 00:41:40 UTC
Red Hat Knowledge Base (Solution) 916853 0 None None None 2017-05-29 13:50:30 UTC
Red Hat Knowledge Base (Solution) 2998291 0 None None None 2017-04-12 03:18:13 UTC

Internal Links: 1450902 1573880

Description Lucy Bopf 2017-02-09 04:17:58 UTC
Several changes were made to the implementation of self-hosted engine RHV 4.1. This affects the way that a self-hosted environment is to be restored in a disaster recovery or migration scenario.

The steps for restoring a self-hosted engine environment must be reviewed and updated.

See the bugs in 'Depends On' for details of the required changes.

Comment 2 Lucy Bopf 2017-03-29 11:53:15 UTC
*** Bug 1422144 has been marked as a duplicate of this bug. ***

Comment 3 Lucy Bopf 2017-03-29 11:59:07 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1422144#c1 for additional details about the backup and restore flow.

Comment 4 Lucy Bopf 2017-03-29 12:55:54 UTC
*** Bug 1431635 has been marked as a duplicate of this bug. ***

Comment 5 Lucy Bopf 2017-03-29 12:57:43 UTC
See https://bugzilla.redhat.com/show_bug.cgi?id=1431635#c0 for prerequisites for avoiding SPM issues while completing a backup and restore (or migration) operation.

Comment 6 Germano Veit Michel 2017-04-12 03:17:58 UTC
Lucy, just finished the customer facing KCS solution we talked about:

https://access.redhat.com/solutions/2998291

Comment 7 Germano Veit Michel 2017-04-12 07:08:32 UTC
Lucy, could you review the KCS? If it's good enough you we can link it in the docs, saving some time. Or even move the contents to the Docs and just put the link to the docs in the KCS.

And since this also works in 4.0.7, maybe 4.0 docs also deserve it?

Comment 8 Lucy Bopf 2017-05-12 06:42:26 UTC
Thanks, Germano! And sorry for the delay.

I'm assigning this one to Byron for review. Byron, can you review the KBase against our current procedures to see how extensive the updates might be?

Comment 9 Yaniv Lavi 2017-05-29 13:50:31 UTC
*** Bug 1108334 has been marked as a duplicate of this bug. ***

Comment 12 Yaniv Lavi 2017-06-13 07:38:53 UTC
*** Bug 1359572 has been marked as a duplicate of this bug. ***

Comment 44 Lucy Bopf 2017-11-21 01:52:14 UTC
*** Bug 1480027 has been marked as a duplicate of this bug. ***

Comment 45 Lucy Bopf 2017-11-21 07:54:54 UTC
*** Bug 1508540 has been marked as a duplicate of this bug. ***

Comment 46 Lucy Bopf 2017-11-21 07:55:44 UTC
*** Bug 1508535 has been marked as a duplicate of this bug. ***

Comment 47 Lucy Bopf 2017-11-28 02:01:30 UTC
*** Bug 1505798 has been marked as a duplicate of this bug. ***

Comment 48 Lucy Bopf 2017-11-28 02:02:32 UTC
Adding another duplicate: bug 1505798

This one is a request for instructions on restoring storage as part of this flow.

Comment 53 Lucy Bopf 2018-03-26 01:11:09 UTC
Moving to the Documentation component and removing targets to allow the docs team to review and re-triage this request.

Comment 54 Lucy Bopf 2018-04-05 00:57:19 UTC
Targeting at 4.3, to be reviewed together with bug 1482710 as part of the overall content strategy for SHE backup and restore.

Comment 55 Lucy Bopf 2018-05-17 00:45:31 UTC
Rescoping this for the 4.2 stream, given the high priority.

Assigning to Tahlia for review. Tahlia, we'll review this in the context of 4.2 only, so it should follow on logically from your GA work on the deployment changes.

Comment 69 Tahlia Richardson 2018-08-06 06:32:06 UTC
Setting the requires_doc_text flag to - since docs bugs don't get release notes.

Comment 90 Polina 2018-10-25 13:03:30 UTC
Hi, 
I'd like to add some note to the restore procedure of the environment with several SDs and one of them is iscsi. If the restore process is running on the re-provisioned host , it probably will fail with STORAGE_DOMAIN_UNREACHABLE error . To prevent this after re-provisioning the host the user must update the /etc/iscsi/initiatorname.iscsi with the right value before the restore process starting.

Comment 91 Simone Tiraboschi 2018-10-25 13:25:06 UTC
(In reply to Polina from comment #90)
> Hi, 
> I'd like to add some note to the restore procedure of the environment with
> several SDs and one of them is iscsi. If the restore process is running on
> the re-provisioned host , it probably will fail with
> STORAGE_DOMAIN_UNREACHABLE error . To prevent this after re-provisioning the
> host the user must update the /etc/iscsi/initiatorname.iscsi with the right
> value before the restore process starting.

This just in the case where iSCSI target doesn't accept every connection but filters them according to initiators ACL, right?

Comment 92 Polina 2018-10-28 07:24:07 UTC
(In reply to Simone Tiraboschi from comment #91)

> 
> This just in the case where iSCSI target doesn't accept every connection but
> filters them according to initiators ACL, right?

right. here is the yaml definition for iscsi:

iscsi_server: "10.35.162.66"
target_id: "iqn.2009-01.com.kaminario:storage.k2.22612"

storages:
  ...
  iscsi_0:
    state: present
    iscsi:
      target: "{{ target_id }}"
      address: "{{ iscsi_server }}"
      lun_id: 20024f40058540070
      override_luns: True

Comment 93 Nikolai Sednev 2018-10-28 08:09:13 UTC
(In reply to Polina from comment #90)
> Hi, 
> I'd like to add some note to the restore procedure of the environment with
> several SDs and one of them is iscsi. If the restore process is running on
> the re-provisioned host , it probably will fail with
> STORAGE_DOMAIN_UNREACHABLE error . To prevent this after re-provisioning the
> host the user must update the /etc/iscsi/initiatorname.iscsi with the right
> value before the restore process starting.

This is really important note, user have to understand that iSCSI mapping should be updated for the hosts, hence initiator iqn must be the same as was mapped on iSCSI target, or changed to new iqn accordingly.

Comment 94 Tahlia Richardson 2018-10-31 23:44:28 UTC
Thanks, I'll add it in.

Comment 95 Nikolai Sednev 2018-11-05 17:01:20 UTC
I have no objections.
Moving to verified.
Please reopen if there will be some additional data needed to be inserted or open a separate documentation bug on it.

Comment 104 Emma Heftman 2018-11-15 08:00:42 UTC
Verified. Waiting to merge.


Note You need to log in before you can comment on or make changes to this bug.