Bug 1420699 - [Docs][RFE][VMM] Document additional changes for the headless feature
Summary: [Docs][RFE][VMM] Document additional changes for the headless feature
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.1.1
: ---
Assignee: Emma Heftman
QA Contact: Byron Gravenorst
URL:
Whiteboard:
Depends On: 1381184
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 10:31 UTC by Sharon Gratch
Modified: 2019-05-07 13:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-14 13:08:24 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Sharon Gratch 2017-02-09 10:31:32 UTC
This new feature supports Headless VMs in oVirt by adding an option to run a VM without any graphical console, for cases in which a graphical console is not needed for accessing this VM. It is supported via WebAdmin, UserPortal and REST api (REST api is partially supported on 4.1 and will be fully supported on 4.2).

RFE: Bug 1381184

Wiki: https://github.com/sgratch/ovirt-site/blob/master/source/develop/release-management/features/virt/headless-vm.html.md

Comment 1 Yaniv Lavi 2017-03-02 13:15:50 UTC
Please consider Bug #1425076 in documenting this feature.

Comment 2 Lucy Bopf 2017-03-14 06:09:24 UTC
The headless feature was identified in https://bugzilla.redhat.com/show_bug.cgi?id=1412051#c5 when Emma was working on general updates for the New/Edit Virtual Machine dialogs, and was subsequently documented.

This documentation is available in section A.1.4 at https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1-beta/html-single/virtual_machine_management_guide/#sect-Explanation_of_Settings_in_the_New_Virtual_Machine_and_Edit_Virtual_Machine_Windows

Closing this bug. Please reopen if any additional changes are required.

*** This bug has been marked as a duplicate of bug 1412051 ***

Comment 3 Sharon Gratch 2017-03-14 07:07:29 UTC
The headless feature includes changes in other dialogs except the New/Edit VM dialogs like "run-Once" and "Instance-type" new/edit dialogs.
Should I reopen this bug?

Comment 4 Lucy Bopf 2017-03-14 12:30:41 UTC
Thanks, Sharon. Yes, I agree with reopening this to make sure those other changes are covered.

Comment 5 Lucy Bopf 2017-04-24 08:46:38 UTC
Assigning to Emma for review.

Comment 6 Emma Heftman 2017-04-24 14:50:58 UTC
Hi Sharon,
From what I understand from the feature page, I believe the documentation should be updated with the following information: which is currently missing

1.  In case of a running VM, changing to headless mode will require a VM restart.

2.  Add headless option to Template, Pool or Instance type documentation

3. Document change made to run once dialog.

4. Document how to access a running vm vs. a new vm.

5. Create a new section describing the headless feature.

Comment 8 Sharon Gratch 2017-04-26 13:43:50 UTC
Hi Emma,

Right. 
Please consider also adding the following issues:

1. In case of a Headless VM,the following UI changes occur:

a. Invoking a graphic console option is disabled and so are all options in the    
  "Console Options" dialog

b. The "Graphics Column" on VMs view and the "General" sub-tab display the  
  "Graphics protocol" and "Video Type" values as "None".

c. Under the "VM devices" sub-tab: no video or graphic devices are displayed.

2. Limitations 
(https://github.com/sgratch/ovirt-site/blob/master/source/develop/release-management/features/virt/headless-vm.html.md#limitations) 
and especially:
Prior to running a VM with a Headless mode, the Grub configuration for this VM should be set to console mode since otherwise the Grub will cause the guest OS boot process to hang.

3. REST API partial support 
(https://github.com/sgratch/ovirt-site/blob/master/source/develop/release-management/features/virt/headless-vm.html.md#rest-api).

Comment 9 Emma Heftman 2017-04-30 09:06:41 UTC
(In reply to Sharon Gratch from comment #8)
> Hi Emma,
> 
> Right. 
> Please consider also adding the following issues:
> 
> 1. In case of a Headless VM,the following UI changes occur:
> 
> a. Invoking a graphic console option is disabled and so are all options in
> the    
>   "Console Options" dialog
I had previously documented that the Enable VirtIO serial console option is still enabled when selecting Headless. Is this incorrect?

> 
> b. The "Graphics Column" on VMs view and the "General" sub-tab display the  
>   "Graphics protocol" and "Video Type" values as "None".
> 
> c. Under the "VM devices" sub-tab: no video or graphic devices are displayed.
> 
> 2. Limitations 
> (https://github.com/sgratch/ovirt-site/blob/master/source/develop/release-
> management/features/virt/headless-vm.html.md#limitations) 
> and especially:
> Prior to running a VM with a Headless mode, the Grub configuration for this
> VM should be set to console mode since otherwise the Grub will cause the
> guest OS boot process to hang.
> 
> 3. REST API partial support 
> (https://github.com/sgratch/ovirt-site/blob/master/source/develop/release-
> management/features/virt/headless-vm.html.md#rest-api).

Comment 10 Emma Heftman 2017-04-30 09:07:55 UTC
Increased the estimate due to discovery that VMM guide is missing information about editing the Console tab of templates, which now needs to be added.

Comment 12 Sharon Gratch 2017-04-30 12:10:04 UTC
(In reply to Emma Heftman from comment #9)
> (In reply to Sharon Gratch from comment #8)
> > Hi Emma,
> > 
> > Right. 
> > Please consider also adding the following issues:
> > 
> > 1. In case of a Headless VM,the following UI changes occur:
> > 
> > a. Invoking a graphic console option is disabled and so are all options in
> > the    
> >   "Console Options" dialog
> I had previously documented that the Enable VirtIO serial console option is
> still enabled when selecting Headless. Is this incorrect?
Yes, it is correct. The Headless mode has no influence on the VirtIO serial console. 
There are 2 console types in console tab: graphical console (which the Headless mode disabled) and serial console. No one influences the other.

Comment 13 Emma Heftman 2017-05-01 09:49:41 UTC
(In reply to Emma Heftman from comment #10)
> Increased the estimate due to discovery that VMM guide is missing
> information about editing the Console tab of templates, which now needs to
> be added.

The Introduction to the User Portal also needs to be updated as connection features will not work in headless mode.

Comment 17 Emma Heftman 2017-05-08 11:43:17 UTC
Hi Byron

Please review this merge request. All details are in the request.
Thanks a lot. Emma


Note You need to log in before you can comment on or make changes to this bug.