Bug 142238 - aspell-bg package uses old/bad sources with wrong encoding
aspell-bg package uses old/bad sources with wrong encoding
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: aspell-bg (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-08 06:56 EST by Doncho N. Gunchev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 10:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my personal aspell-bg.spec (1.67 KB, text/plain)
2004-12-08 06:58 EST, Doncho N. Gunchev
no flags Details
Proposed patch (1.30 KB, patch)
2005-01-15 14:29 EST, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Doncho N. Gunchev 2004-12-08 06:56:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
    aslell-bg sources are big mess. I talked to Radostin Radnev,
aspell-bg's author, about this (bug #128137, comment 9). For some
reason all words in the old tarbals have all words preffixed with
their first letter (2 times more and 50% wrong words).

Version-Release number of selected component (if applicable):
aspell-bg-0.50-7

How reproducible:
Always

Steps to Reproduce:
0. Install aspell-bg
1. echo 'яма' | aspell --encoding=utf-8 --lang=bg -a # good word
2. echo 'яяма' | aspell --encoding=utf-8 --lang=bg -a # bad word
3. echo 'яма' | iconv -f utf-8 -t koi8-r | aspell  --lang=bg -a
4. echo 'яяма' | iconv -f utf-8 -t koi8-r | aspell  --lang=bg -a

Actual Results:
1 fails because aspell-bg is packed with koi8-r encoding, which is
wrong, our encoding is cp-1251.
2 fails like 1, but should suggest:
--- cut --
echo 'яяма' | aspell --encoding=utf-8 --lang=bg -a # good word
@(#) International Ispell Version 3.1.20 (but really Aspell 0.50.5)
& яяма 8 0: яма, няма, ярма, ама, аязма, Ява, Яна, явна
--- cut ---
3 works because iconv gives it the expected encoding
4 works, but should fail like 2

Expected Results:
$ echo 'яма' | aspell --encoding=utf-8 --lang=bg -a
@(#) International Ispell Version 3.1.20 (but really Aspell 0.50.5)
*

$ echo 'яяма' | aspell --encoding=utf-8 --lang=bg -a
@(#) International Ispell Version 3.1.20 (but really Aspell 0.50.5)
& яяма 8 0: яма, няма, ярма, ама, аязма, Ява, Яна, явна


Additional info:

I'll attaching my .spec file that results in working package. If any
aditional information is needed I'm ready to assist.
Comment 1 Doncho N. Gunchev 2004-12-08 06:58:11 EST
Created attachment 108102 [details]
my personal aspell-bg.spec
Comment 2 Yanko Kaneti 2004-12-16 20:39:05 EST
I can confirm Doncho's observations and his fix (use only the tarball
from sourceforge) works for me.

It would seem that another official update is in order since the
current aspell-bg in updates is efectively broken for all normal purposes.
Comment 3 Yanko Kaneti 2004-12-16 20:48:14 EST
Err... of course, what I meant was that Doncho's fix is using only the
aspell-bg-0.50-2.tar.bz2 tarball and not aspell-bg-4.0.tar.gz
Comment 4 Doncho N. Gunchev 2005-01-13 03:33:57 EST
    Is there something else I can do to for this package?
Comment 5 Yanko Kaneti 2005-01-15 14:29:44 EST
Created attachment 109825 [details]
Proposed patch

Here is a patch against FC-3 cvs to the effect of the changes proposed above.
Comment 6 Ivana Varekova 2005-02-24 09:39:23 EST
Thank you for your notices.
I fixed this problem, the corrected version will be 0.50-9
Ivana Varekova
Comment 7 Doncho N. Gunchev 2005-03-24 02:56:16 EST
This bug looks forgotten for me, still 0.50-7 in updates, nothing in testing.
Looking at devel I found 0.50-9 and it is ok. Why fixing such a simple problem
takes soo much time?
Comment 8 Doncho N. Gunchev 2005-04-16 07:37:55 EDT
Still not fixed in FC3 (in FC4t2 it is ok), reopening.
Comment 9 Ivana Varekova 2005-04-19 10:51:06 EDT
This bug is fixed in fc3 (in 0.50-8.fc3 version).
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.