Bug 206420 - [indic] unable to display numeric characters during input
[indic] unable to display numeric characters during input
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n, Reopened
Depends On: 142712
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 06:05 EDT by Ankit Patel
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 08:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankit Patel 2006-09-14 06:05:18 EDT
+++ This bug was initially created as a clone of Bug #142712 +++

Description of problem:
In the indic locale, when entering numeric characters when Input
Method is turned off, the numeric characters cannot be seen.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-17.6.EL4

How reproducible:
Always

Steps to Reproduce:
1.LANG=hi_IN.UTF-8 ooimpress
2.AutoPilot Presentation, proceed with all the default options
3.Select "Empty Presentation" (default) and click Next
4.Click Next at the slide design leaving everything as default
5.Click Next at the slide transition with everything as default
6.Click Create
7.Click OK at the "AutoLayout"
8.enter "123abc"   

Actual results:
Unable to see the numeric characters entered

Expected results:
Should be able to see the numeric characters entered

Additional info:
Affects all 5 Indic locale.

-- Additional comment from llim@redhat.com on 2004-12-16 01:30 EST --
Bug still exist in openoffice.org-i18n-1.1.2-18.6.EL4

-- Additional comment from llch@redhat.com on 2005-01-27 15:24 EST --
Still exist in 1.1.3-2.5. Would it be because Indic fonts does not
have numeric glyphs?

-- Additional comment from llim@redhat.com on 2005-03-01 04:08 EST --
Dan,
Tried with the libvcl645li.so file you gave me yesterday.
Unfortunately, the bug still exist with the .so file.


Thanks,
Lawrence

-- Additional comment from caolanm@redhat.com on 2005-03-21 07:19 EST --
Still strange with 1.9.84-1

-- Additional comment from caolanm@redhat.com on 2005-06-14 19:25 EST --
dan has done some glyph fallback stuff for 2.0, can you try with OOo 1.9.109-4
or above from rawhide/fc4-update-candidate and verify that it's working.

-- Additional comment from dff@redhat.com on 2005-06-15 04:14 EST --
PM ACK for U2.

-- Additional comment from caolanm@redhat.com on 2005-06-15 10:57 EST --
This is something to do with the code behind tools->options->Complex Text
Layout->Numerals I actually thing. Will look for the bit to backport.

-- Additional comment from llim@redhat.com on 2005-06-15 19:40 EST --
Tested with openoffice.org-core-1.9.109-5.1.0.fc4, numeric characters are now
able to display during input.

-- Additional comment from caolanm@redhat.com on 2005-06-16 10:54 EST --
*** Bug 157915 has been marked as a duplicate of this bug. ***

-- Additional comment from llim@redhat.com on 2005-06-20 21:20 EST --
Tested with dist/4E-scratch/openoffice.org/1.1.2-26.6.0.EL4, the fix is looking
great for all 5 indic locale. :-)


Thanks!

-- Additional comment from caolanm@redhat.com on 2005-07-27 04:31 EST --
1.1.2-28.6.0.EL4

-- Additional comment from bugzilla@redhat.com on 2005-10-05 12:27 EST --

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-665.html


-- Additional comment from bugzilla@redhat.com on 2005-10-05 12:30 EST --

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-665.html


-- Additional comment from caolanm@redhat.com on 2005-12-20 04:04 EST --
*** Bug 174970 has been marked as a duplicate of this bug. ***
Comment 1 Caolan McNamara 2006-09-15 05:27:43 EDT
> rpm -q openoffice.org-langpack-hi_IN openoffice.org-core
openoffice.org-core-2.0.4-3.1
openoffice.org-langpack-hi_IN
> LANG=hi_IN.UTF-8 ooimpress
123abc

-> I can't see a problem here.

What does tools->openoffice.org->language settings->complex text
layout->Numerals say ? 

(though I tried all three options under hi_IN and all worked for me, reopen if I
missed how to reproduce this)
Comment 2 Ankit Patel 2006-09-15 06:06:54 EDT
Caolan,

I am reopening this bug, because it's still there.

If you try to type "123abc" then it won't show the problem because few letters
are added together with digits (I don't know how it works), but if you try to
input only digits, eg. "123" only, then you can face the problem.

For your reference, i am pasting the link of screenshots which i have attached
in the older bugs:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=121837
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=121838

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=121839
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=121840

One more thing i noticed that If i go to the link
"tools->openoffice.org->language settings->complex text layout->Numerals", then
it shows three languages, which are different from my locale. e.g. If you run
openoffice in gu_IN interface, then this option shows, "Hindi, Arabic, System
Default" Numerals and if you run openoffice in hi_IN interface, then this option
shows, "Hungarian, Arabic, System Default" Numerals. If this also affects the
result, then please consider it too...
Comment 3 Caolan McNamara 2006-09-15 06:57:59 EDT
The specific 1.1.X problem that this was cloned from was supposed to be fixed
long ago, and is probably not the exact same problem as you face today, and I
need to get a grip on what is not working the way you want.

Can you restate, without reference to the 1.1.X problems, what the problem is
currently for 2.0.4 (i.e. devel) ? and which locale you are finding this problem in.

I've tried a fresh ooo 2.0.4 in gu_IN, typed 123 in calc/impress/writer without
the input engine active as per comment #1 and got 123, pressed tab to move a new
cell and it remained as 123. The above 1.1.X screenshots refer to calc, while
the initial comment in the clone refers to impress, but for both cases, out of
the box. typing numbers in a cell/impress box without IM active and then leaving
the cell/impress in a gu_IN locale is retaining the numerals in the same format
before and after. 

The 1.1.X problem was basically that "system" was the 1.1.X default for
numerals, while it is now "arabic" because the semi-modal behavour of "system"
numerals was confusing for people.
Comment 4 Ankit Patel 2006-09-15 07:44:50 EDT
To get the digits in a particular language, input engine must be active/enabled
before typing.

And refer this two links only:

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=121837
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=121838
Comment 5 Caolan McNamara 2006-09-15 08:35:08 EDT
ok, cloned comment #1 was "In the indic locale, when entering numeric characters
when Input Method is turned off, the numeric characters cannot be seen." and
goes on to talk about presentations. I think that has led us astray a bit.

Here we are instead talking about with the input engine turned on, and I suspect
only with calc, not with writer or with presentations. Here's what is the
expected behaviour with native language numerals...

a) when typed into writer the characters remain exactly the same when e.g.
return is pressed, or the editing is finished
b) into impress, like writer the numerals remain the same during and after
editing the text box (the 1.1.X bug was that the numerals changed after leaving
the edit box for e.g. impress)
c) into calc, mixed numerals and text are considered "text" and remain the same
during editing of a cell and after leaving the cell
d) into calc, but *only* numerals are typed. This is taken by calc and converted
to an internal number representation, which is the same regardless of how
numbers are entered. And this internal number represenation is then afterwards
displayed using the default numeric display formatting. 

So, I suspect that here our problem is d), where you type 1,2,3 in an indic
format into a calc cell, see 123 in an indic format, leave the cell like in the
pictures, and it turns into western (arabic) 123

The "text" entered is shown as the typed letters until editing of the cell is
finished, then if the cell is a number it is displayed using the number format.
Which is default "arabic" numbers for all locales.

The "default" number formatting can be overriden by the setting mentioned above
in the settings, in which case e.g. both a western 123 entered would be
re-displayed in the selected format as well as an indic 123. 

Additionally it can be overriden for a given cell with NatNum, search for NatNum
in the calc help for details.

Note You need to log in before you can comment on or make changes to this bug.