Bug 143059 - No sound from snd_cs46xx
No sound from snd_cs46xx
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 146342 146958 162305 (view as bug list)
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2004-12-15 23:39 EST by Terry Griffin
Modified: 2015-01-04 17:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 16:50:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Griffin 2004-12-15 23:39:16 EST
Description of problem:

To the parade of reports of no sound I'm adding the snd_cs46xx
driver.

Version-Release number of selected component (if applicable):

kernel-2.6.9-1.667
kernel-2.6.9-1.678_FC3
kernel-2.6.9-1.681_FC3


How reproducible:

100%

Steps to Reproduce:
1. Get yourself a laptop with a CS46xx sound chip such as an IBM A20m. 
2. Install FC3.
3. Run system-config-soundcard and see that the sound chip is
detected correctly.
4. Click "play" and see that no error messages are display.
  
Actual results:

No sound.

Expected results:

Sound.

Additional info:

Works fine with FC1.
Comment 1 Andre Robatino 2004-12-16 23:14:18 EST
  Is this an ISA PnP device?  If so, it's probably a dupe of bug
#139323 (though I'm still waiting for a response).
Comment 2 Terry Griffin 2004-12-16 23:49:51 EST
No, it's not ISA PnP. It's a PCI device. 
 
Comment 3 Terry Griffin 2005-01-17 21:57:56 EST
I finally got it to work. The rough procedure is: (1) When the sound 
config utility asks if you heard the sample sound, lie and say you 
heard it. This will configure the drivers. (2) Then bring up a sound 
mixer utility and fiddle around with the settings until you get 
sound. 
 
So it looks like the basic problem is that the sound config utility 
is not coming up with good default mixer settings when it plays the 
sample sound. 
 
Comment 4 Dave Jones 2005-02-03 01:21:03 EST
*** Bug 146342 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2005-02-03 01:21:08 EST
*** Bug 146958 has been marked as a duplicate of this bug. ***
Comment 6 Ricky Ng-Adam 2005-02-12 16:00:10 EST
I can confirm the same problem with a Thinkpad A22M.

Vendor: Cirrus
Model: Logic CS 4613/22/24 [CrystalClear SoundFusion Audio Accelerator]
Module: snd-cs46xx

Comment 7 Noah Romer 2005-03-20 17:44:24 EST
Just in case there're people out there who haven't got the sound working with
the more recent FC kernels, here's what I changed to make it work:

In whatever mixer you're using, set the "External Amplifier" switch to "On." 

I'd given up on all but the original FC3 kernel until today; my comp crashed
when I unplugged my printer's USB cable, figure that out, and ate my 2.6.9-1.667
installation. I had to boot the 2.6.10-1.760_FC3 kernel I had installed,
planning on grabbing 2.6.9-1.667 off the CD, but thought I might as well give
sound under 2.6.10 another whirl and viola!

Must be because the speakers have their own power supply and volume controls.
Can you even buy any that don't these days?
Comment 8 Ricky Ng-Adam 2005-03-25 01:56:16 EST
snd-cs46xx/a22m seems to work with FC4 test 1: at the first boot install dialog,
I just have to put the volume up and I can hear the test sound.
Comment 9 Dave Jones 2005-07-07 18:14:26 EDT
*** Bug 162305 has been marked as a duplicate of this bug. ***
Comment 10 Dave Jones 2005-07-15 16:46:05 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 11 Anders Montonen 2005-08-01 13:54:23 EDT
I get no sound from my Game Theater XP in FC4, running kernel 2.6.12-1.1398_FC4.
The card is detected OK, music playing software work fine, but no sound comes
from any output, regardless of the mixer settings. Used to work in FC2 which was
previously installed on this machine.
Comment 12 Ricardo Sanz 2005-09-08 16:17:24 EDT
Same problem here with FC4 in my IBM T21 Laptop, kernel 2.6.12-1.1447_FC4.

The sound card gets detected, but no sound its produced. all setings of the
sound mixer testes, no sound at all.

The module for the card (snd_cs46xx:) gets loaded with an error (/var/log/messages):

Sep  8 12:35:48 t21gsc kernel: snd_cs46xx: Unknown parameter `'

Comment 13 Charlie Brady 2005-09-17 15:15:29 EDT
I have no sound from snd_cs46xx, with FC4, kernel 2.6.12-1.1447_FC4, on a
Thinkpad T21. IRQ is 11, shared with "uhci:usb1, yenta, yenta", and interrupts
increment during the soundcard detection/test.
Comment 14 Panu Matilainen 2005-10-05 01:44:26 EDT
Me too - full silence on T21 although otherwise sound system seems otherwise
functional. A collegue pointed me to this which might explain the thing:
http://www.ces.clemson.edu/linux/alsa.shtml. I'll give it a try on weekend when
I next have access to the box...
Comment 15 Panu Matilainen 2005-10-07 13:18:31 EDT
Ok, finally got sound out of this thing (T21). The trick, found by lots of
random experimentation since there's no "jack sense" control on this thing, was
to unmute DAC channel in Gnome volume control. That DAC setting needs to be
first enabled from the preferences and to confuse matters even more, it's on the
"Capture" tab which isn't the most obvious place to look at when there's no
sound *output* :-/
Talk about obscure.. oh well, happy now as sound now works, hopefully this helps
others as well. 
Comment 16 Peter Fales 2005-10-21 15:19:35 EDT
Thanks for taking the time to write that.   The same fix (turn up the volume on
the DAC channel) was needed on my thinkpad T22.   I never would have figiured
that out on my own!
Comment 17 Dave Jones 2005-11-04 16:50:00 EST
The ALSA people seem to have a preoccupation with moving things around each
release for some reason.  Glad you have this working again.

Note You need to log in before you can comment on or make changes to this bug.