Bug 143541 - firewire device causes scsi bus resets
firewire device causes scsi bus resets
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 21:41 EST by Suchandra Thapa
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suchandra Thapa 2004-12-21 21:41:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
Attaching a firewire device to the firewire port on my sb audigy 2zs causes scsi errors on my lsi 21320 card.  Since I'm using scsi hard drives this causes the system to lock up for up to a minute while the scsi bus is reset.  The problems seem to arise randomly.  The log messages that appear follow:

Dec 20 10:09:30 hepcat kernel: mptscsih: ioc0: >> Attempting task abort! (sc=106cc9c0)
Dec 20 10:09:32 hepcat kernel: mptbase: Initiating ioc0 recovery
Dec 20 10:09:35 hepcat kernel: mptbase: ioc0: ERROR - Doorbell INT timeout (count=4999), IntStatus=80000000!
Dec 20 10:09:35 hepcat kernel: mptscsih: ioc0: Issue of TaskMgmt failed!
Dec 20 10:09:35 hepcat kernel: mptscsih: ioc0: WARNING - Error issuing abort task! (sc=106cc9c0)
Dec 20 10:09:35 hepcat kernel: mptscsih: ioc0: >> Attempting bus reset! (sc=106cc9c0)


This may be related to bugs 126162, 138894, and 140356 

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3smp

How reproducible:
Sometimes

Steps to Reproduce:
Running the system with the firewire device causes the errors to appear after a while.

Additional info:
Comment 1 Suchandra Thapa 2004-12-25 01:03:51 EST
Actually, the bug is quite a bit worse than I thought.  The resets somehow also
cause a SMART logical failure to be logged to the scsi hard drives on the
channel.  So if the devices are left running long enough, the drives will report
a SMART failure warning.  This is with atlas 10K III drives, I'm not sure if
this will appear with other scsi hard drives.
Comment 2 Suchandra Thapa 2005-02-03 15:03:45 EST
I think this may be a hardware.  One of the scsi channels and the
firewire device share an irq and I've managed to get errors in winxp
when the firewire device is running.   Given the age of the
motherboard (440BX smp system), I think it probably didn't fully meet
some spec and this is a result of that.
Comment 3 Dave Jones 2005-07-15 14:19:32 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Suchandra Thapa 2005-07-15 16:17:38 EDT
You can close this bug.  The problem was a failing scsi drive on one of the scsi
channels raising errors and causing bus resets.  Replacing the hard drive fixed
the problem.

Note You need to log in before you can comment on or make changes to this bug.