Bug 14455 - [laptop]kudzu causes lcd backlight to go off and stay off until powercycle
[laptop]kudzu causes lcd backlight to go off and stay off until powercycle
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-22 05:42 EDT by Hans de Goede
Modified: 2014-03-16 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-24 16:59:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-07-22 05:42:04 EDT
Whne kudzu is run it turns of the lcd backlight of my no name (chaplet
5023) p133 laptop. Very shortly ofterwards kudzu crashes with the following
message (read through a normal monitor attached to the laptop):
---
Checking for new hardware/etc/rc.d/init.d/kudzu: line: 56   584
Segmentationfault     (core dumped) /usr/sbin/kudzu $KUDZU_ARGS -t 30
---

This might be very well related to the installer doing the same (turning of
the backlight) when running the post install stuff I will enter this
shortly and add a comment with the bug no.

This might also be related to Xconfigurator dumping core on the same
laptop, although without turning of the backlight. I will enter this
shortly and add a comment with the bug no.

Note this is against beta3, I'll retest with beta4 this monday, no time
this weekend.
Comment 1 Hans de Goede 2000-07-22 05:52:12 EDT
Related:

Backlight off during post install config in text install: bug 14456
No Xsetup done during text install: bug 14457
Xconfigurator segfaulting: bug 14458

Comment 2 Bill Nottingham 2000-07-22 16:31:10 EDT
*** Bug 14456 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2000-07-22 16:32:03 EDT
What does running 'kudzu -s' do?
Comment 4 Hans de Goede 2000-07-24 16:59:27 EDT
Nothing, iow that seems to work fine.

I guess I should give a noprobe to the installer to get his behaviour in the
installer too? (For fixing bug 14456)

If that is the case, and if the -s flags will be automaticly added to the flags,
kudzu is started with when the installer is started with noprobe, this could be
considered fixed as far as I'm concerend.
Comment 5 Bill Nottingham 2000-07-24 17:04:18 EDT
OK. The DDC probe will be removed from normal kudzu
invocations, as soon as I figure out a good clean way
to do it. :)

Note You need to log in before you can comment on or make changes to this bug.