Bug 14456 - [laptop - text] lcd backlight turned off untill power cycle in post install configuration
[laptop - text] lcd backlight turned off untill power cycle in post install c...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Winston rc1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-22 05:44 EDT by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 15:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2000-07-22 05:44:37 EDT
When a text install on my chaplett 5023 laptop (p133) reaches the post
install screen shortly afterwards (before the making of the boot disk) it
turns off my lcd backlight, only powercycling can restore it.

Kudzu does the same when run on boot btw, see bug 14455
Comment 1 Hans de Goede 2000-07-22 05:53:10 EDT
Probably also related:

No Xsetup done during text install: bug 14457
Xconfigurator segfaulting: bug 14458

Comment 2 Bill Nottingham 2000-07-22 16:31:12 EDT
That's because kudzu is run during the post install. :)

*** This bug has been marked as a duplicate of 14455 ***
Comment 3 Hans de Goede 2000-07-27 17:03:50 EDT
Just did a fresh install of beta5 booting from the pcmcia floppy with:
linux noprobe

The laptop still goes black, so either the noprobe option is no longer used /
not the right option to use, or what I believe, doesn't stop kudzu from dcc
probing.
Comment 4 Glen Foster 2000-07-30 14:32:07 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 5 Bill Nottingham 2000-07-31 10:43:43 EDT
Does it still happen at exactly the same place in the
install?
Comment 6 Michael Fulbright 2000-08-01 14:21:21 EDT
The noprobe option is not used in interactive installs. 

This cannot be fixed at this time - you can continue the install successfully so
if your X configuration needs
touchup you can run Xconfigurator after you reboot.
Comment 7 Hans de Goede 2000-08-05 14:40:26 EDT
First of all, the screen goes completly black, so this is a cannot complete
install bug, not everyone has a spare monitor handy to plug in, and other
systems are bound to be bitten by this too.

The help screens on the bootdisks clearly state that you can use expert mode to
install on buggy hardware, and that in this case no autoprobing will be done.

I would expect noprobe todo a normal install, without any probing as in expert
mode. That is what I plea for, and what afaik 6.1 used todo.

But letts say I use expert mode, then I presume kudzu won't do dcc probing and
Xconfigurator will be run with --nodccprobe? If not I concider that a bug, and I
strongly urge for a noprobe option doing the noprobing effect of expert without
all the other questions I don't want to answer and have no need for. If this is
not feasible for this release, then fix this in expert mode, and defer the
noprobe RFE.
Comment 8 Hans de Goede 2000-08-05 15:05:38 EDT
And yes, afaik it still happens in exact the same spot in the install.
Comment 9 Hans de Goede 2000-08-08 10:25:35 EDT
Correction, now it happens after the bootdisk creation screen, and before beta5
it happended before this screen afair (as far as I remember). So this means that
I now can just blindly press enter, since Xconfigurator crashes also.

Now if you guys also added an automatic reboot if nothing is done for 15
seconds, then this bug might go unnoticed ;)
Comment 10 Erik Troan 2000-08-08 15:34:01 EDT
Fixed internally (expert mode passes --noddcprobe)
Comment 11 Hans de Goede 2000-08-08 15:43:39 EDT
Actually that would fix bug 14457, do you also stop kudzu from doing the ddc probe, that causes the blackscreen, see bug 14455.

So to be very clear, kudzu used to blank the screen, that was fixed for regular boots by not doing dcc probes on regular boots, but kudzu still does the 
dcc thing in the installer (even in expert mode the screen goes blank)

And Xconfigurator crashes, that is supposed to be fixed by a new Xconfigurator in general, and it can also be fixed by passing the -nodccprobe, which is 
what should happen in expert mode.

So the fix is correct, but does this stop kudzu from dcc-probing too, since that causes this bug, passing -noddcprobe to Xconfigurator actually should fix 
bug 14457

Note You need to log in before you can comment on or make changes to this bug.