Bug 14501 - Host name set to localhost.localdomain
Host name set to localhost.localdomain
Status: CLOSED DUPLICATE of bug 16482
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Erik Troan
Winston rc1
: 15107 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2000-07-23 20:01 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-09-14 16:40:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/etc/sysconfig/network (66 bytes, text/plain)
2000-08-05 10:20 EDT, Christian Rose
no flags Details

  None (edit)
Description Christian Rose 2000-07-23 20:01:03 EDT
Performed a text install with beta4.
After the install, the machine reports "localhost.localdomain" as its host
name, although I entered "toblerone.menthos.com" as the host name in the
network setup in the install.
Host name setting appears to be broken.
Comment 1 Glen Foster 2000-07-30 15:36:06 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
... I think there are some dups of this defect floating around -- they should be
Comment 2 Erik Troan 2000-07-31 15:14:56 EDT
Brock, please help.
Comment 3 Christian Rose 2000-08-03 07:38:31 EDT
I don't know if this is related, but this machine sits behind an IP-masquerading
box. If the installer somehow performs a reverse DNS lookup to verify the
hostname, well obviously it will get the wrong IP/host name back, and thus maybe
revert to localhost.localdomain?

I noticed that the /etc/hosts listed the external IP of my masquerading box
together with the host name of the beta box, which is obviously wrong.

If the installer tries a reverse DNS lookup and then reverts to
localhost.localdomain if the lookup returns an other result than expected it's
wrong, because there are many situations like this where a reverse lookup will
fail but the installer should work just fine if it trusted and used the entered
Comment 4 Glen Foster 2000-08-04 09:50:25 EDT
*** Bug 15107 has been marked as a duplicate of this bug. ***
Comment 5 Erik Troan 2000-08-05 09:51:31 EDT
Was /etc/hosts correct, and just /etc/sysconfig/network wrong, or were both
Comment 6 Christian Rose 2000-08-05 10:19:39 EDT
In my case, both were somewhat wrong.

I don't have the original /etc/hosts left, but as I remember it had the   localhost      localhost.localdomain
line correct, but listed the hostnames of the machine (toblerone.menthos.com,
toblerone) together with the IP of the firewall/masquerading box on the next

/etc/sysconfig/network has the hostname wrong, as you can see (will attach it).
Comment 7 Christian Rose 2000-08-05 10:20:22 EDT
Created attachment 2095 [details]
Comment 8 Pekka Savola 2000-08-07 04:15:09 EDT
Host resolution goes wrong if DNS is not reachable.  See #13486 for the same
thing in GUI.
Comment 9 Michael Redinger 2000-08-13 11:40:38 EDT
Server Text install does the same thing in RC1. However, I remember Workstation
(KDE) install said "Setting hostname to localhost.localdomain" at startup but
showed the right hostname at the KDE login screen. Didn't test DNS resolution

text server install: /etc/hosts says:		FQHN	HN	localhost.localdomain	localhost

(this might also be the reason why the KDE login screen shows the hostname).


/etc/resolv.conf is ok (search domain written correctly).
Comment 10 Erik Troan 2000-08-14 14:46:45 EDT
The rules for doing this seem to get it right "most of the time". We'll revisit
this for Florence, but we're nervous about breaking things.
Comment 11 Michael Fulbright 2000-09-14 16:40:48 EDT

*** This bug has been marked as a duplicate of 16482 ***

Note You need to log in before you can comment on or make changes to this bug.