Bug 145383 - Missing update announcement
Missing update announcement
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks: 141256
  Show dependency treegraph
 
Reported: 2005-01-17 16:50 EST by Bernd Bartmann
Modified: 2014-01-21 17:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 17:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2005-01-17 16:50:21 EST
Description of problem:
The update announcement is missing on fedora-announce list.


Version-Release number of selected component (if applicable):
dovecot-0.99.13-2.FC3

How reproducible:


Steps to Reproduce:
1. look for an update announcement
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Dennis 2005-01-17 17:00:37 EST
it was written, but held pending resolution of a new issue. I will
include it for your reference. The rpm is being superceded as we
speak, the actual update announcement will be for new rpm.

---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2005-028
2005-01-14
---------------------------------------------------------------------

Product     : Fedora Core 3
Name        : dovecot
Version     : 0.99.13                      
Release     : 2.FC3                  
Summary     : Dovecot Secure imap server
Description :
Dovecot is an IMAP server for Linux/UNIX-like systems, written with
security
primarily in mind.  It also contains a small POP3 server.  It supports
mail
in either of maildir or mbox formats.

---------------------------------------------------------------------
Update Information:

This is a bug fix update for the Dovecot IMAP server. This brings the
Red Hat Dovecot rpm up to date with the latest upstream release from
Timo Sirainen, version 0.99.13 released on Jan 6th 2005.

Upstream Fixes are noted below and below that are Red Hat specific
fixes.

Please note there have been some changes to the /etc/dovecot.conf
file. When the rpm installs it will probably create
/etc/dovecot.conf.rpmnew file with the new version of the config file
while preserving your previous /etc/dovecot.conf file. It would be
prudent to compare the two files and see if you need to adjust your
configuration.

Aside from the upstream fixes notable change in the RPM include:

- University of Washington Imap (UW Imap) migration documentation and
  scripts in the doc area (/usr/share/doc/dovecot-*)

- More example configurations in the doc area.

- The script to generate SSL certificates (mkcert in the doc area) now
  is congruent with Red Hat's OpenSSL rpm.

- The init.d script now starts dovecot later (it used to start it
  before named). If this problem was affecting your installation
  you'll have to chkconfig del and add to recreate the rc.d sym links,
  new installations will automatically pick up the new start order.

- Add a Red Specific FAQ to the doc area, mostly to address issues
  some sites were having with dot lock file creation.

====== Upstream Fixes ======

0.99.13

	* GNUTLS support hasn't been working for a while, so it's not even
	  tried to be used anymore unless explicitly wanted.
	+ Added CRAM-MD5 authentication mechanism. Patch by Joshua Goodall
	+ Added SMD5 and LDAP-MD5 password schemes and changed MD5 scheme to
	  use LDAP-MD5 if the password isn't in MD5crypt format. Patch by
	  Joshua Goodall
	+ Workaround for some POP3 client bugs: if message doesn't contain the
	  "end of headers" empty line, add it automatically.
	+ vpopmail supports now all password schemes, most importantly
	  MD5crypt works now without support from libc's crypt()
	- SQL and LDAP authentication was broken
	- SEARCH UNKEYWORD wasn't working

0.99.12

	- Fix memory leaks in LDAP, MySQL and PGSQL userdb/passdb
	- Fix hanging when parsing mails that have over 4096 bytes in one
	  line (SMTP servers normally don't allow over 1000 bytes so it
	  shouldn't be much of a problem)
	- FETCH BODYSTRUCTURE sometimes gave a wrong reply
	  (eg. with FETCH (BODYSTRUCTURE RFC822.SIZE) if it wasn't cached)
	- Never return more than one INBOX in LIST even if there are such
	  files. They don't work anyway and it just confuses clients.
	- mbox: Don't allow creating INBOX directory by creating/renaming
	  mailboxes under it. They just wouldn't work.
	- POP3: Don't return PLAIN in SASL list. We don't support initial SASL
	  responses, so it only breaks with most clients that try to use it.
	- IMAP and POP3 login processes may have sent each line in two IP
	  packets, one with the data and another with CR+LF. Some clients
	  didn't work because of this.

====== Red Hat RPM Fixes ======

- add REDHAT-FAQ.txt to doc directory
- fix bug #143707, bring up to date with latest upstream, 0.99.13, 
- fix bug #14462, bad dovecot-uid macro name
- fix bug #133618, removed LITERAL+ capability from capability string
- fix bug #134325, stop dovecot during installation
- fix bug #129539, dovecot starts too early,
  set chkconfig to 65 35 to match cyrus-imapd
- fix bug #139954, add UW to Dovecot migration documentation and scripts
- fix bug #139276, fix SSL documentation and scripts, add missing
documentation
- fix bug #136623 Change License field from GPL to LGPL to reflect
  actual license
- fix bug #124786, listen to ipv6 as well as ipv4

---------------------------------------------------------------------
* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.FC3

- make postgres & mysql conditional build
- remove execute bit on migration example scripts so rpm does not pull
  in additional dependences on perl and perl modules that are not present
  in dovecot proper.
- add REDHAT-FAQ.txt to doc directory

* Fri Jan 07 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.FC3

- bring up to date with latest upstream, 0.99.13, bug #143707

* Thu Jan 06 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel

- fix bug #133618, removed LITERAL+ capability from capability string

* Wed Jan 05 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel

- fix bug #134325, stop dovecot during installation

* Wed Jan 05 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel

- fix bug #129539, dovecot starts too early,
  set chkconfig to 65 35 to match cyrus-imapd
- also delete some old commented out code from SSL certificate creation

* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel

- add UW to Dovecot migration documentation and scripts, bug #139954
  fix SSL documentation and scripts, add missing documentation, bug
#139276

* Mon Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1

- rebuild against MySQL4


---------------------------------------------------------------------
This update can be downloaded from:
  http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/

904cbb48e640de7f4103d3c8c98dc70d  SRPMS/dovecot-0.99.13-2.FC3.src.rpm
10f41d07659ed95d452eb4fae53a5fc8  x86_64/dovecot-0.99.13-2.FC3.x86_64.rpm
c75a76e2afeb40c7257a22972adb59f4 
x86_64/debug/dovecot-debuginfo-0.99.13-2.FC3.x86_64.rpm
5e7cc2ee655d828cceaf83619c30323f  i386/dovecot-0.99.13-2.FC3.i386.rpm
773d93b2b3ddef5b141faf27ecfb020f 
i386/debug/dovecot-debuginfo-0.99.13-2.FC3.i386.rpm

This update can also be installed with the Update Agent; you can
launch the Update Agent with the 'up2date' command.  
---------------------------------------------------------------------

Note You need to log in before you can comment on or make changes to this bug.