Bug 145415 - wireless-tools changed soname between 27 and 28
wireless-tools changed soname between 27 and 28
Status: CLOSED DUPLICATE of bug 145395
Product: Fedora
Classification: Fedora
Component: wireless-tools (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 145416 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 23:37 EST by matty
Modified: 2014-01-21 17:51 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 09:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description matty 2005-01-17 23:37:57 EST
wireless-tools-28-0.pre4.1fc3:1
Comment 1 matty 2005-01-17 23:38:28 EST
[root@localhost *****]# yum update
Setting up Update Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2622/2622
primary.xml.gz            100% |=========================| 216 kB    00:02
MD Read   : ################################################## 514/514
updates-re: ################################################## 514/514
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package wireless-tools.i386 1:28-0.pre4.1.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: libiw.so.27 for package: NetworkManager
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package wireless-tools.i386 1:27-0.pre25.2 set to be updated
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Update: wireless-tools.i386 1:28-0.pre4.1.fc3

Performing the following to resolve dependencies:
  Update: wireless-tools.i386 1:27-0.pre25.2
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Check Error:   file /sbin/ifrename conflicts between
attempted installs of wireless-tools-27-0.pre25.2 and
wireless-tools-28-0.pre4.1.fc3
  file /sbin/iwconfig conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /sbin/iwevent conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /sbin/iwgetid conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /sbin/iwlist conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /sbin/iwpriv conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /sbin/iwspy conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/include/iwlib.h conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/include/wireless.h conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/lib/libiw.so conflicts between attempted installs of
wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/share/man/man5/iftab.5.gz conflicts between attempted
installs of wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/share/man/man8/ifrename.8.gz conflicts between attempted
installs of wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/share/man/man8/iwconfig.8.gz conflicts between attempted
installs of wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/share/man/man8/iwevent.8.gz conflicts between attempted
installs of wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/share/man/man8/iwgetid.8.gz conflicts between attempted
installs of wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
  file /usr/share/man/man8/iwspy.8.gz conflicts between attempted
installs of wireless-tools-27-0.pre25.2 and wireless-tools-28-0.pre4.1.fc3
[root@localhost *****]#
Comment 2 Ville Skyttä 2005-01-18 03:40:26 EST
*** Bug 145416 has been marked as a duplicate of this bug. ***
Comment 3 Ville Skyttä 2005-01-18 03:42:37 EST
If this stays in, kdenetwork (and a whole bunch of other apps, I gather) will
need to be rebuilt and updated too.
Comment 4 Duncan Gibb 2005-01-18 07:05:38 EST
Updating FC3 (at least with up2date or yum) is currently broken due to this.

kdenetwork needs libiw.so.27, but something else (still looking for exactly
what) triggers wireless-tools to be updated to 28, even if yum is run with a
glob which should exclude it.  The RPM transaction falls apart at this stage.
Comment 5 Seth Vidal 2005-01-18 08:54:13 EST
you can 'unbreak' yum by excluding wireless-tools


like this:
yum --exclude=wireless-tools update

that lets the transaction finish for me.
Comment 6 Dan Williams 2005-01-18 09:20:21 EST

*** This bug has been marked as a duplicate of 145395 ***

Note You need to log in before you can comment on or make changes to this bug.