Bug 145707 - Text/Formatting differences on user prefs page on hosted
Text/Formatting differences on user prefs page on hosted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ken Ganong
Red Hat Satellite QA List
:
: 128894 145776 145830 (view as bug list)
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2005-01-20 14:27 EST by Michael Bowman
Modified: 2007-04-18 13:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 10:37:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Bowman 2005-01-20 14:27:09 EST
Description of problem:
Textual differences between perl/java User preference pages.
Comment 1 Ken Ganong 2005-01-24 09:12:26 EST
*** Bug 145830 has been marked as a duplicate of this bug. ***
Comment 2 Ken Ganong 2005-01-24 09:13:06 EST
*** Bug 145776 has been marked as a duplicate of this bug. ***
Comment 3 Ken Ganong 2005-01-24 09:15:26 EST
*** Bug 128894 has been marked as a duplicate of this bug. ***
Comment 4 Ken Ganong 2005-01-24 09:17:13 EST
This comment originally made by jesusr on a duplicate of this bug.

At current we are using the hard coded list of timezones ported from
the perl codebase.  We should look at using the java.util.TimeZone
class to populate the drop down.

To keep compatibility we could limit the list items using a lower and
upper bound so it works with our current schema.
Comment 5 Ken Ganong 2005-02-01 14:26:38 EST
TimeZones are now saved by a TimeZone object.  UserFactory sorts them
for display purposes.  The format is not localized.
Comment 6 Ken Ganong 2005-02-04 10:37:11 EST
Timezones are now localized using StringResource.  All references to
the display name of timezones in the database have been removed.

Note You need to log in before you can comment on or make changes to this bug.