Bug 1460954 - vdsm-client package install fails on older (3.6 compat) nodes
vdsm-client package install fails on older (3.6 compat) nodes
Status: VERIFIED
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.VDSM (Show other bugs)
1.7.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: 1.7.0
Assigned To: Sandro Bonazzola
Radim Hrazdil
:
Depends On:
Blocks: 1489016
  Show dependency treegraph
 
Reported: 2017-06-13 04:52 EDT by Sahina Bose
Modified: 2017-09-28 05:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: planning_ack+
sbonazzo: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78810 master MERGED vdsm: fallback on vdsm-cli if vdsm-client is missing 2017-06-29 11:43 EDT

  None (edit)
Description Sahina Bose 2017-06-13 04:52:38 EDT
Description of problem:

When a node is added to the 3.6 cluster level, installation fails with error message 
Failed to install Host hostnamex. Failed to execute stage 'Package installation': Package vdsm-client cannot be found.

vdsm-client is not available in older vdsm.

Version-Release number of selected component (if applicable):
1.7-master

How reproducible:
Always


Additional info:
Downstream gluster nodes have vdsm 4.17 version and do not have the vdsm-client package.
Is there a way to conditionally check for packages (vdsm-client /vdsm-cli) based on cluster level?
Comment 1 Martin Perina 2017-06-13 05:33:23 EDT
We had a similar discussion in BZ1417687, isn't it possible to use 4.1 host instead of 3.6 one? 4.1 hosts should work fine even in 3.6 clusters ...
Comment 2 Sahina Bose 2017-06-13 06:41:27 EDT
No..The problem is that we want to use oVirt 4.2 to manage older nodes. The only way to do that is to add these to a 3.6 cluster..upgrading the nodes is not an option.
Bug 1443508 was filed to make collectd packages optional to fix the similar issue you mention in Comment 1
Comment 4 Martin Perina 2017-06-13 07:04:36 EDT
(In reply to Sahina Bose from comment #2)
> No..The problem is that we want to use oVirt 4.2 to manage older nodes. The
> only way to do that is to add these to a 3.6 cluster..upgrading the nodes is
> not an option.
> Bug 1443508 was filed to make collectd packages optional to fix the similar
> issue you mention in Comment 1

We for 4.2 we plan to consolidate host dependencies inside ovirt-host package (more details at BZ1460609), but if we really want to fix that issue, we would need to create ovirt-host package also for 3.6 (as those are on different channel than 4.x hosts) and provide 3.6 async with NGN. Sandro?
Comment 7 Sandro Bonazzola 2017-06-14 10:15:03 EDT
(In reply to Martin Perina from comment #4)
> (In reply to Sahina Bose from comment #2)
> > No..The problem is that we want to use oVirt 4.2 to manage older nodes. The
> > only way to do that is to add these to a 3.6 cluster..upgrading the nodes is
> > not an option.
> > Bug 1443508 was filed to make collectd packages optional to fix the similar
> > issue you mention in Comment 1
> 
> We for 4.2 we plan to consolidate host dependencies inside ovirt-host
> package (more details at BZ1460609), but if we really want to fix that
> issue, we would need to create ovirt-host package also for 3.6 (as those are
> on different channel than 4.x hosts) and provide 3.6 async with NGN. Sandro?

Honestly, not sure that a 4.2 feature is worth to be backported to 3.6.
Please note ovirt-host-deploy is not installing vdsm-client directly.
Can you please share the full ovirt-host-deploy log?
Comment 8 Sandro Bonazzola 2017-06-14 10:18:48 EDT
(In reply to Sandro Bonazzola from comment #7)

> Honestly, not sure that a 4.2 feature is worth to be backported to 3.6.
> Please note ovirt-host-deploy is not installing vdsm-client directly.
> Can you please share the full ovirt-host-deploy log?

Actually it is: https://gerrit.ovirt.org/#/c/71235/
Comment 9 Sandro Bonazzola 2017-06-14 10:20:44 EDT
I guess we can just change:
self.packager.installUpdate(('vdsm', 'vdsm-client'))

in
self.packager.installUpdate(('vdsm',))
try:
    self.packager.installUpdate(('vdsm-client',))
except Exception:
    self.packager.installUpdate(('vdsm-cli',))

Not really elegant but should be enough for this legacy handling.
Comment 10 Martin Perina 2017-06-14 10:24:04 EDT
(In reply to Sandro Bonazzola from comment #8)
> (In reply to Sandro Bonazzola from comment #7)
> 
> > Honestly, not sure that a 4.2 feature is worth to be backported to 3.6.
> > Please note ovirt-host-deploy is not installing vdsm-client directly.
> > Can you please share the full ovirt-host-deploy log?
> 
> Actually it is: https://gerrit.ovirt.org/#/c/71235/

Yes, because vdsm-client is a vdsm-cli replacement in 4.1/4.2. So on virt side we are OK with adding 4.1/4.2 hosts into 3.6 cluster without any issues, but this is not an option for gluster, right @Sahina?


(In reply to Sandro Bonazzola from comment #9)
> I guess we can just change:
> self.packager.installUpdate(('vdsm', 'vdsm-client'))
> 
> in
> self.packager.installUpdate(('vdsm',))
> try:
>     self.packager.installUpdate(('vdsm-client',))
> except Exception:
>     self.packager.installUpdate(('vdsm-cli',))
> 
> Not really elegant but should be enough for this legacy handling.

Hmm, wouldn't it be better to create ovirt-host-3.6 with proper dependencies for 3.6 rather then above fix?
Comment 11 Sandro Bonazzola 2017-06-28 07:24:38 EDT
(In reply to Martin Perina from comment #10)

> Hmm, wouldn't it be better to create ovirt-host-3.6 with proper dependencies
> for 3.6 rather then above fix?

We are not releasing anymore packages for 3.6 and 4.0 in oVirt.
So only solution here seems to be comment #9
Comment 12 Oved Ourfali 2017-06-28 08:38:13 EDT
After talking to Sandro, moving to integration team.
Comment 14 Sandro Bonazzola 2017-06-29 11:48:28 EDT
Looks like this affects ovirt-host-deploy 1.7 only, 1.6 (engine 4.1) still install vdsm-cli, not vdsm-client.
Comment 15 Radim Hrazdil 2017-09-07 05:45:31 EDT
Verified that in Version 4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos, installation of 3.6 host to 3.6 cluster succeeds. Vdsm-cli is installed instead of vdsm-client.

Note You need to log in before you can comment on or make changes to this bug.