Bug 1462276 - [3.5] Ansible playbook fails due the incorrect openshift-master.kubeconfig
[3.5] Ansible playbook fails due the incorrect openshift-master.kubeconfig
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.1
Unspecified Unspecified
high Severity urgent
: ---
: 3.5.z
Assigned To: Andrew Butcher
Gaoyun Pei
:
Depends On: 1454321 1462280 1462282 1462283 1465263
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 11:13 EDT by Andrew Butcher
Modified: 2017-12-18 22:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, installation would fail in multi-master environments in which the load balanced API was listening on a different port than that of the OpenShift API/console. We now account for this difference and ensure the master loopback client config is configured to interact with the local master.
Story Points: ---
Clone Of: 1454321
Environment:
Last Closed: 2017-06-29 09:33:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Gaoyun Pei 2017-06-27 02:29:37 EDT
Test this bug with openshift-ansible-3.5.88-1.git.0.9901d92.el7.noarch

Set openshift_master_cert_expire_days to 365 to workaround BZ#1465263.
Once BZ#1465263 fixed, will move this bug to verified.

1. Prepare an haproxy load-balancer openshift-133.test.com listens on 443 while the backend masters listen on 8443, make sure 443 and 8443 port opened.

2. Configure inventory file like below
[OSEv3:children]
masters
nodes
etcd

[OSEv3:vars]
<-snip->
openshift_master_cluster_method=native
openshift_master_cluster_hostname=openshift-133.test.com
openshift_master_cluster_public_hostname=openshift-133.test.com

penshift_master_console_port=8443
openshift_master_api_port=8443

openshift_master_api_url=https://openshift-133.test.com:443
openshift_master_console_url=https://openshift-133.test.com:443/console
openshift_master_public_api_url=https://openshift-133.test.com:443
openshift_master_public_console_url=https://openshift-133.test.com:443/console
<-snip->

[masters]
...

3. Run installation playbook
The installation is successful without error, ocp cluster is working well.

4. Check openshift-master.kubeconfig on 3 masters
The user referred in openshift-master.kubeconfig are all pointing to local master with correct port.

5. Stop 2/3 masters' controllers service in turn, each of the 3 masters could work well.
Comment 4 Scott Dodson 2017-06-28 09:11:05 EDT
Gaoyun, sounds like from your last comment the bug can be moved to VERIFIED?
Comment 5 Gaoyun Pei 2017-06-28 22:20:24 EDT
Yes, actually this bug have been fixed with openshift-ansible-3.5.88-1, but still need workaround to continue the installation. Since BZ#1465263 was verified with openshift-ansible-3.5.91-1.git.0.28b3ddb.el7.noarch, mark this bug also verified with openshift-ansible-3.5.91-1.git.0.28b3ddb.el7.noarch.
Comment 7 errata-xmlrpc 2017-06-29 09:33:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1666

Note You need to log in before you can comment on or make changes to this bug.