Bug 1462283 - [3.2] Ansible playbook fails due the incorrect openshift-master.kubeconfig
[3.2] Ansible playbook fails due the incorrect openshift-master.kubeconfig
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.2.1
Unspecified Unspecified
high Severity urgent
: ---
: 3.2.1
Assigned To: Andrew Butcher
Gaoyun Pei
: NeedsTestCase
Depends On: 1454321
Blocks: 1462276 1462280 1462282
  Show dependency treegraph
 
Reported: 2017-06-16 11:17 EDT by Andrew Butcher
Modified: 2017-06-29 09:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1454321
Environment:
Last Closed: 2017-06-29 09:33:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Scott Dodson 2017-06-23 12:57:21 EDT
In the latest puddle.
Comment 5 Gaoyun Pei 2017-06-26 22:49:09 EDT
Verify this bug with atomic-openshift-utils-3.2.60-1.git.0.f082225.el7.noarch.rpm

1. Prepare an haproxy load-balancer listens on 443 while the backend masters listen on 8443, make sure 443 and 8443 port opened on lb host

2. Configure inventory file like below
[OSEv3:children]
masters
nodes
etcd

[OSEv3:vars]
<-snip->
openshift_master_cluster_method=native
openshift_master_cluster_hostname=openshift-140.test.com
openshift_master_cluster_public_hostname=openshift-140.test.com

penshift_master_console_port=8443
openshift_master_api_port=8443

openshift_master_api_url=https://openshift-140.test.com:443
openshift_master_console_url=https://openshift-140.test.com:443/console
openshift_master_public_api_url=https://openshift-140.test.com:443
openshift_master_public_console_url=https://openshift-140.test.com:443/console
<-snip->

[masters]
...

3. Run installation playbook
The installation is successful without error, ocp cluster is working well.

4. Check openshift-master.kubeconfig on 3 masters
The user referred in openshift-master.kubeconfig are all pointing to local master with correct port.

5. Stop 2/3 masters' controllers service in turn, each of the 3 masters could work well.
Comment 7 errata-xmlrpc 2017-06-29 09:33:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1666

Note You need to log in before you can comment on or make changes to this bug.