Bug 1463505 - DNF errors with "Assertion `ret == 0' failed."
DNF errors with "Assertion `ret == 0' failed."
Status: CLOSED DUPLICATE of bug 1463561
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 03:17 EDT by Jiří Vymazal
Modified: 2017-06-21 07:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 03:45:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Vymazal 2017-06-21 03:17:13 EDT
Description of problem:
Cannot use dnf

Version-Release number of selected component (if applicable):
1.1.10
  Installed: dnf-0:1.1.10-6.fc25.noarch at 2017-03-28 08:29
  Built    : Fedora Project at 2017-03-15 08:52

  Installed: rpm-0:4.13.0.1-1.fc25.x86_64 at 2017-03-28 08:29
  Built    : Fedora Project at 2017-02-24 12:48

How reproducible:
run any dnf command (tried install, update, upgrade)

Steps to Reproduce:
1. $ sudo dnf upgrade

Actual results:
system-python: /builddir/build/BUILD/hawkey-0.6.4/src/sack.c:354: load_ext: Assertion `ret == 0' failed.
zsh: abort      sudo dnf upgrade

Expected results:
dnf upgrade runs

Additional info:
before this started happening dnf timed out on probably some back-end connection
issue and encountered Transaction check error concerning dnf-installed and gem-installed rake packages.
Comment 1 Jiří Vymazal 2017-06-21 03:26:11 EDT
Also tried running "sudo dnf clean all" but it did not help.
Comment 2 Igor Gnatenko 2017-06-21 03:45:35 EDT
rm -rf /var/cache/dnf/*

DNF 1.x is unsupported and will get only security fixes, so closing.
Comment 3 Jiří Vymazal 2017-06-21 04:28:26 EDT
Ok, just how am I supposed to "correctly" upgrade dnf to supported version (and by the way why is this not handled (semi-)automatically during dnf upgrade)? The work-around you listed above worked only for one dnf command after it and now no longer works at all. Tried also reboot and coupling your work-around with dnf clean all but nothing helps.
Comment 4 Igor Gnatenko 2017-06-21 05:24:09 EDT
*** Bug 1463582 has been marked as a duplicate of this bug. ***
Comment 5 Igor Gnatenko 2017-06-21 05:24:16 EDT
*** Bug 1463580 has been marked as a duplicate of this bug. ***
Comment 6 Jacek Pawlyta 2017-06-21 07:09:20 EDT
Jiri,
In ma case updates-testing repo caused the error.

Disabling it helps:

dnf --disabelrepo=updates-tetsing update


Igor, 
there is no any other version of dnf than 1.x in any official fedora 25 repos.
What should we use then?
Comment 7 Jacek Pawlyta 2017-06-21 07:14:14 EDT
I think the bug should be be reopened with hight priority beacuse it blocks updating the system.
Comment 8 Igor Gnatenko 2017-06-21 07:14:55 EDT

*** This bug has been marked as a duplicate of bug 1463561 ***

Note You need to log in before you can comment on or make changes to this bug.