Bug 1464099 - [BZ] Stale bucket index entries are left over after object deletions
[BZ] Stale bucket index entries are left over after object deletions
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.3
x86_64 Linux
high Severity high
: rc
: 2.3
Assigned To: Matt Benjamin (redhat)
Vasishta
Bara Ancincova
:
: 1479771 (view as bug list)
Depends On:
Blocks: 1473188 1496568
  Show dependency treegraph
 
Reported: 2017-06-22 08:25 EDT by Benjamin Schmaus
Modified: 2017-09-27 15:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHEL: ceph-10.2.7-28.el7cp Ubuntu: ceph_10.2.7-30redhat1
Doc Type: Bug Fix
Doc Text:
Due to an incorrect time comparison in the rgw_dir_suggest_changes() function, under certain circumstances, deleted objects were incorrectly interpreted as incomplete delete transactions. As a consequence, the delete operations were reported successful in the Ceph Object Gateway logs, but the deleted objects were not correctly removed from bucket indexes. The incorrect time comparison has been fixed, and deleting objects works correctly.
Story Points: ---
Clone Of:
: 1496568 (view as bug list)
Environment:
Last Closed: 2017-07-17 13:06:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 20380 None None None 2017-06-22 08:25 EDT

  None (edit)
Description Benjamin Schmaus 2017-06-22 08:25:06 EDT
Description of problem:

We have already hit this issue once on the cluster (cdc-obj-100) running RH versioned binaries (ceph version 10.2.5-28.2.bz1445891redhat1xenial).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

See http://tracker.ceph.com/issues/20380

Actual results:


Expected results:


Additional info:
Comment 35 Vasishta 2017-07-13 02:49:26 EDT
Hi all,

Using script mentioned in Comment 3, created, deleted 0.1M+ objects.
Working fine for me, Moving to VERIFIED state

Regards,
Vasishta
Comment 37 errata-xmlrpc 2017-07-17 13:06:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1755
Comment 39 Benjamin Schmaus 2017-08-30 14:59:15 EDT
*** Bug 1479771 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.