Bug 146431 - OOcalc: Printouts cut off at bottom of page when "fit printout to number of pages" used
OOcalc: Printouts cut off at bottom of page when "fit printout to number of p...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 144922 146956 147369 153027 (view as bug list)
Depends On:
Blocks: 153027
  Show dependency treegraph
 
Reported: 2005-01-27 22:11 EST by Charles Taylor
Modified: 2007-11-30 17:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 06:16:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A test spreadsheet that prints properly in earlier versions of oocalc (5.87 KB, application/octet-stream)
2005-01-27 22:14 EST, Charles Taylor
no flags Details
Openoffice spreadsheet which does not work on OO 1.1.3 with FC3 (19.11 KB, text/plain)
2005-01-28 05:39 EST, Ryan Vietri
no flags Details

  None (edit)
Description Charles Taylor 2005-01-27 22:11:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
In OOO 1.2 as shipped with FC3, and in all previous versions, you
could select from the menu Format/Page/Sheet/Fit printout on number of
pages [1] to fit a particular sheet of a spreadsheet so that it would
print on a single page.  When this option is set with the ooo
mentioned in this bug report, the bottom of the spreadsheet gets cut
off in both the "Print Preview" option and in the printout itself.


Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-2.5.fc3

How reproducible:
Always

Steps to Reproduce:
1.Create a spreadsheet
2.Format/Page/Sheet/Fit printout on number of pages [1]
3.Print.  If the spreadsheet was large enough to need resizing to fit
on one page, the bottom of the sheet will be cut off.
    

Actual Results:  Printout was cut off at the bottom.

Expected Results:  Printout should have been adjusted to fit on a
single page.


Additional info:
Comment 1 Charles Taylor 2005-01-27 22:14:15 EST
Created attachment 110341 [details]
A test spreadsheet that prints properly in earlier versions of oocalc

This is a test spreadsheet that illustrates the problem. In the previous FC3
openoffice version, this sheet is correctly shrunk to fit on a single page when
printing.  In the current FC3 openoffice version, it's cut off at the bottom
when printed or previewed.
Comment 2 Ryan Vietri 2005-01-28 05:39:58 EST
Created attachment 110347 [details]
Openoffice spreadsheet which does not work on OO 1.1.3 with FC3

This spreadsheet does not preview or print correctly on OO 1.1.3 with FC3 but
worked perfectly on all previous versions as well as OO 1.1.3 Windows version
and Mac version.
Comment 3 Ryan Vietri 2005-01-28 05:43:05 EST
I am having the same problem however it cuts of edges on the sides as
well as the bottom. I have little doubt it is the same bug though.
Spreadsheets which work fine will all Windows/Mac OO versions and on
FC3 with OO 1.1.2 no longer page preview or print correctly at all. I
have made an attachment illustrating this. The page preview and print
should speak for themselves. 

Perhaps this bug should be given higher priority if it is affecting
everyone or at least the 1.1.3 "upgrade" should be removed from the
repository until the cause is found.
Comment 4 G.Wolfe Woodbury 2005-02-01 09:32:38 EST
Additionally, it fails to format multiple pages on a spreadsheet
properly.  It tries to cram everyting into one page and fails to
indicate the page and column breaks on the screen.
It also affects the PDF preview.
Comment 5 Eddie Sturgis 2005-02-04 11:55:40 EST
*** Bug 146956 has been marked as a duplicate of this bug. ***
Comment 6 Fabio Insaccanebbia 2005-02-12 18:26:25 EST
The title of the bug is now a bit misleading... there's no need to set
the option "fit printout to number of pages" to see the bug 146956
(that has been considered a duplicate of this bug).
Comment 7 Ryan Vietri 2005-02-12 20:35:39 EST
Agreed, the "fit printout to number of pages" is not required not does
it only cut off at the bottom of the page. 
Comment 8 Caolan McNamara 2005-02-16 08:56:55 EST
*** Bug 147369 has been marked as a duplicate of this bug. ***
Comment 9 James Ralston 2005-02-17 18:06:26 EST
This is a pretty severe regression, as I can't find *any* way to get
properly-sized output out of OO 1.3 calc--even PDF exports are chopped off.

I dropped back to 1.1.2-11.5.fc3, which doesn't have this problem.  (I didn't
try either of 1.1.3-2.5.fc3 or 1.1.3-5.5.0.fc3.)
Comment 10 Ryan Vietri 2005-02-17 18:12:43 EST
It is very severe. Rendering 1.1.3 unusable for producing any printed output
which is a basic requirement in our environment. Due to this problem I installed
and am running 1.9.77 and will be changing to 1.9.79. Besides the odd crash now
and then it is working brilliantly.
Comment 11 Charles Taylor 2005-02-17 20:34:16 EST
I created a new user accound and installed (./install --single) the single-user
version of Openoffice.org 1.1.3.

With the official Open Office 1.1.3 build, my test case (posted with the bug
report) DOES preview and print correctly.  So whatever causes this bug doesn't
appear to be in OOo proper.  It's only in the Fedora-shipped builds of OOo 1.1.3.

(Sorry about being TOO specific with the bug report.  At the time I reported the
bug, I had only tested cases with the "Fir to number of pages" option on, since
that's almost always how I use Calc with my large gradebook spreadsheets.)
Comment 12 Dan Williams 2005-02-17 22:16:05 EST
I'm working on this issue already, a fix MUST be done by early March in any
case, so it will be addressed quite soon.
Comment 13 Dan Williams 2005-02-17 22:17:43 EST
BTW, has anyone tried to address this by moving the page breaks in View->Page
Break Preview?
Comment 14 Heikki Paajanen 2005-02-18 02:00:50 EST
I've been inserting manual page breaks as a work around. It seems that automatic
page breaks are not inserted (or maybe page size is not respected so that page
can be arbitrarily large? .anyway, just guessing...)
Comment 15 Dan Williams 2005-02-28 20:07:23 EST
*** Bug 144922 has been marked as a duplicate of this bug. ***
Comment 16 Bob Gustafson 2005-03-04 17:18:57 EST
Yes, a serious problem...
Comment 17 Dan Williams 2005-03-07 00:55:58 EST
Fixed in:

RHEL3: 1.1.2-22.2.2.EL3
RHEL4: 1.1.2-22.6.EL4
FC2: 1.1.3-9.4.0.fc3
FC3: 1.1.3-9.5.0.fc3
devel: 1.9.82-1
Comment 18 Charles Taylor 2005-03-10 08:22:10 EST
Potentially dumb question here, but I'd like to test the fixed
openoffice.org RPMs, and I can't find openoffice.org-1.1.3-9.5.0.fc3
RPMs anywhere (they don't seem to be in the updates or testing
repositories).  Can someone give me a pointer to the RPMs?  All I see
are openoffice.org-1.1.3-6.5.0.fc3 packages.

Comment 19 Charles Taylor 2005-03-14 09:23:13 EST
Now that the openoffice.org-1.1.3-9.5.0.fc3 packages are in the
updates repository, I've tested them with my original spreadsheets
that showed the problem and they print and preview properly now. 
Looks like this bug is squished.  Thank you!
Comment 20 Ryan Vietri 2005-03-15 09:20:08 EST
openoffice.org-1.1.3-9.5.0.fc3 resolves this issue. This bug may be
marked as closed.
Comment 21 Dan Williams 2005-04-01 09:32:05 EST
*** Bug 153027 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.