Bug 1464554 - using --inconsistent-index when remove a bucket can result in bucket index corruption
using --inconsistent-index when remove a bucket can result in bucket index co...
Status: CLOSED DUPLICATE of bug 1477311
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.3
Unspecified Unspecified
low Severity medium
: rc
: 3.0
Assigned To: Matt Benjamin (redhat)
ceph-qe-bugs
Erin Donnelly
:
Depends On:
Blocks: 1437916
  Show dependency treegraph
 
Reported: 2017-06-23 14:17 EDT by Orit Wasserman
Modified: 2017-08-17 22:30 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
.The --inconsistent-index option of the radosgw-admin bucket rm should never be used Using the `--inconsistent-index` option with `radosgw-admin bucket rm` can cause corruption of the bucket index if the command fails or is stopped. Do not use this option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-17 22:30:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orit Wasserman 2017-06-23 14:17:04 EDT
Description of problem:
Using  --inconsistent-index with bucket rm can cause corruption of the bucket index if the command fails or stopped. We need to document it and warn the user

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run bucket rm  --inconsistent-index
2. Stop it during the execution
3. 

Actual results:


Expected results:


Additional info:
Comment 2 Matt Benjamin (redhat) 2017-08-17 22:30:21 EDT

*** This bug has been marked as a duplicate of bug 1477311 ***

Note You need to log in before you can comment on or make changes to this bug.