Bug 1477311 - Restrict --inconsistent-index flag from radosgw-admin bucket rm command because it can cause corrupted bucket index
Summary: Restrict --inconsistent-index flag from radosgw-admin bucket rm command becau...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 3.0
Assignee: Orit Wasserman
QA Contact: Ramakrishnan Periyasamy
Bara Ancincova
URL:
Whiteboard:
Keywords:
: 1464554 (view as bug list)
Depends On:
Blocks: 1437916 1494421
TreeView+ depends on / blocked
 
Reported: 2017-08-01 18:20 UTC by Vikhyat Umrao
Modified: 2017-12-05 23:39 UTC (History)
8 users (show)

(edit)
.The `--inconsistent-index` option has been restricted

Using the `--inconsistent-index` option with the `radosgw-admin bucket rm` command could cause corruption of the bucket index if the command failed or was stopped. With this update, usage of `--inconsistent-index` requires a confirmation from users (the `--yes-i-really-mean-it` option), and a warning is printed when attempting to use this option.
Clone Of:
(edit)
Last Closed: 2017-12-05 23:39:05 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC
Ceph Project Bug Tracker 20777 None None None 2017-08-30 20:04 UTC

Description Vikhyat Umrao 2017-08-01 18:20:32 UTC
Description of problem:
Remove --inconsistent-index flag from radosgw-admin bucket rm command because it can cause corrupted bucket index

For more information please check:
https://bugzilla.redhat.com/show_bug.cgi?id=1463969#c8

We have a new feature request: https://bugzilla.redhat.com/show_bug.cgi?id=1475859([RFE] Add parallelism in radosgw-admin bucket rm command for bucket removal) which will help faster deletion and then we do not this flag --inconsistent-index.


Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 2.3

Comment 2 Matt Benjamin (redhat) 2017-08-18 02:30:21 UTC
*** Bug 1464554 has been marked as a duplicate of this bug. ***

Comment 3 Matt Benjamin (redhat) 2017-08-30 18:49:23 UTC
The current plan is to restrict rather than disable --inconsistent-index, PR is here:

https://github.com/ceph/ceph/pull/17185

(assigning to Orit, author of this PR)

Comment 4 Ken Dreyer (Red Hat) 2017-08-30 20:04:32 UTC
Orit would you please cherry-pick this to luminous for Ceph v12.2.1?

Comment 10 Ramakrishnan Periyasamy 2017-10-17 09:29:33 UTC
Moving this bug to Verified state. Command output when tried to purge objects using "--inconsistent-index" param.

[ubuntu@host006 ~]$ sudo radosgw-admin --cluster qetest bucket rm --purge-objects --bypass-gc --inconsistent-index --bucket=test
using --inconsistent_index can corrupt the bucket index 
do you really mean it? (requires --yes-i-really-mean-it)

Comment 15 errata-xmlrpc 2017-12-05 23:39:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.