Bug 1464563 - [3.5] Observed a panic: Pop() of key not in store:
Summary: [3.5] Observed a panic: Pop() of key not in store:
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.5.z
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1477358 (view as bug list)
Depends On: 1447928 1464567 1477358
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-23 18:37 UTC by Phil Cameron
Modified: 2020-12-14 08:56 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: coding error Consequence: Pop() panics and stops router Fix: origin PR 14232 Result:
Clone Of: 1447928
Environment:
Last Closed: 2017-07-11 10:47:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ose pull 796 0 None None None 2017-06-23 18:58:48 UTC
Origin (Github) 14232 0 None None None 2017-06-23 18:37:05 UTC
Red Hat Product Errata RHBA-2017:1640 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5 and 3.4 bug fix update 2017-07-11 14:47:16 UTC

Comment 1 Eric Paris 2017-06-27 15:28:07 UTC
https://github.com/openshift/ose/pull/796

Comment 3 Hongan Li 2017-06-30 05:15:20 UTC
verified in atomic-openshift-3.5.5.31-1.git.0.b6f55a2.el7.x86_64, no panic found in router logs by the script:

#!/bin/bash


function _simulate_eq_panic() {
    sleep 0.0$((RANDOM%3))
    echo "  - worker name: $1 ... "

    case "$((RANDOM%3))" in
      0)  oc create  -f "$2"  ;;
      1)  oc replace -f "$2"  ;;
      2)  oc delete  -f "$2"  ;;
      *)  oc replace -f "$2"  ;;
    esac

}  #  End of function  _simulate_eq_panic.


#
#  main():
#
routefile=${1:-"https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/routing/unsecure/route_unsecure.json"}
ntimes=${2:-50}

for i in `seq ${ntimes}`; do
  _simulate_eq_panic "worker_${i}" "${routefile}" &
done

Comment 5 errata-xmlrpc 2017-07-11 10:47:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1640

Comment 6 Eric Paris 2017-08-02 12:57:38 UTC
*** Bug 1477358 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.