Bug 1464567 - [3.4] Observed a panic: Pop() of key not in store:
Summary: [3.4] Observed a panic: Pop() of key not in store:
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.4.1
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.4.z
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1464475 (view as bug list)
Depends On: 1447928 1477358
Blocks: 1464563
TreeView+ depends on / blocked
 
Reported: 2017-06-23 19:04 UTC by Phil Cameron
Modified: 2020-12-14 08:56 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: coding error Consequence: Pop() panics and stops router Fix: origin PR 14232 Result:
Clone Of: 1447928
Environment:
Last Closed: 2017-07-11 10:47:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ose pull 797 0 None None None 2017-06-27 16:15:18 UTC
Origin (Github) 14232 0 None None None 2017-06-23 19:04:22 UTC
Red Hat Product Errata RHBA-2017:1640 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5 and 3.4 bug fix update 2017-07-11 14:47:16 UTC

Comment 1 Ben Bennett 2017-06-27 16:15:18 UTC
PR https://github.com/openshift/ose/pull/797

Comment 3 zhaozhanqi 2017-06-30 03:10:13 UTC
verified this bug on 
openshift v3.4.1.44
kubernetes v1.4.0+776c994
etcd 3.1.0-rc.0

No found panic in router logs by the script 

#!/bin/bash


function _simulate_eq_panic() {
    sleep 0.0$((RANDOM%3))
    echo "  - worker name: $1 ... "

    case "$((RANDOM%3))" in
      0)  oc create  -f "$2"  ;;
      1)  oc replace -f "$2"  ;;
      2)  oc delete  -f "$2"  ;;
      *)  oc replace -f "$2"  ;;
    esac

}  #  End of function  _simulate_eq_panic.


#
#  main():
#
routefile=${1:-"https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/routing/unsecure/route_unsecure.json"}
ntimes=${2:-50}

for i in `seq ${ntimes}`; do
  _simulate_eq_panic "worker_${i}" "${routefile}" &
done

Comment 5 errata-xmlrpc 2017-07-11 10:47:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1640

Comment 6 Phil Cameron 2017-08-02 14:10:00 UTC
*** Bug 1464475 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.