Bug 146817 - busted dhclient-3.0.1-10_EL3
busted dhclient-3.0.1-10_EL3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: dhcpcd (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: Regression
: 150651 153107 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 16:08 EST by Daniel Wharton
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 12:04:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Wharton 2005-02-01 16:08:53 EST
Description of problem:

I am having a problem with the latest dhclient rpm which prevents it
from creating the propper resolv.conf.  The existing resolv.conf is
properly moved to resolv.conf.predhclient but a new one isn't created.

It seems line 52 of /sbin/dhclient-script calls a function or script
which doesn't exist.  

line from /sbin/dhclient-script:

change_resolv_conf $rscf

Version-Release number of selected component (if applicable):

dhclient-3.0.1-10_EL3

How reproducible: Always


Steps to Reproduce:
1. Install dhclient-3.0.1-10_EL3
2. DHCP from a dhcp server which provides resolv.conf information
  
Actual results:

output when running dhclient:

Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth1/00:XX:XX:XX:XX:XX
Sending on   LPF/eth1/00:XX:XX:XX:XX:XX
Listening on LPF/eth0/00:XX:XX:XX:XX:XX
Sending on   LPF/eth0/00:XX:XX:XX:XX:XX
Listening on LPF/lo/
Sending on   LPF/lo/
Listening on LPF/bond0/00:XX:XX:XX:XX:XX
Sending on   LPF/bond0/00:XX:XX:XX:XX:XX
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on lo to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPREQUEST on bond0 to 255.255.255.255 port 67
DHCPACK from 10.X.X.X
SIOCADDRT: File exists
/sbin/dhclient-script: line 52: change_resolv_conf: command not found
bound to 10.X.X.X -- renewal in 12886770 seconds.

/etc/resolv.conf isn't created

Expected results:

should create /etc/resolv.conf with proper information provided by the
dhcp server

Additional info:

The function simply needs to copy the contents of $rscf to
/etc/resolv.conf.

If I replace line 52 with:

cp $rscf /etc/resolv.conf && chmod 644 /etc/resolv.conf

everything works fine.

that is pretty lame though
Comment 2 Jason Vas Dias 2005-02-07 12:04:51 EST
It looks like you may not have the latest "initscripts" package .
dhcp-3.0.1-10_EL3 was designed to work with initscripts-7.31.17.EL+ ,
whose '/etc/sysconfig/network-scripts/network-functions' script
implements the 'change_resolv_conf' function required by 
/sbin/dhclient-script . This function is also implemented in the 
latest initscripts-7.31.21.EL package for RHEL-3, and in RHEL-3-U4's
initscripts-7.32.18.EL package .  
Use 'up2date' to update to latest RHEL-3-U4 build and obtain 
initscripts-7.32.18.EL to fix this problem.



Comment 3 Jason Vas Dias 2005-02-07 12:20:12 EST
One more point - if 'rpm -q initscripts' reports that you have
initscripts-7.32.18.EL, it may have installed the network-functions
script as  /etc/sysconfig/network-scripts/network-functions.rpmnew ,
if you had modified the original network-functions script from the
previous initscripts package. In this case, backup network-functions,
and copy network-functions.rpmnew to network-functions.
Comment 4 Jason Vas Dias 2005-04-02 15:03:33 EST
*** Bug 150651 has been marked as a duplicate of this bug. ***
Comment 5 Jason Vas Dias 2005-04-02 15:07:27 EST
*** Bug 153107 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.