Bug 1470382 - [Docs][HowTo] SR-IOV steps need clarification
[Docs][HowTo] SR-IOV steps need clarification
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
4.1.2
Unspecified Unspecified
high Severity high
: ovirt-4.1.6
: ---
Assigned To: Byron Gravenorst
Megan Lewis
: Documentation
: 1469842 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-12 17:27 EDT by Jason
Modified: 2017-09-18 02:16 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-18 02:16:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2017-07-12 17:27:17 EDT
Description of problem:

Steps in the Administration Guides for 3.6, 4.0 and 4.1 are not clear cut.

Version-Release number of selected component (if applicable):




Actual results:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/index.html

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.0/pdf/administration_guide/Red_Hat_Virtualization-4.0-Administration_Guide-en-US.pdf

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/pdf/administration_guide/Red_Hat_Virtualization-4.1-Administration_Guide-en-US.pdf

Expected results:

According to a RH Senior Cloud Solutions Architect the Guides should be more clear cut about the steps required:

SRIOV configuration Steps:


1) Enable virtualization extension, IOMMU function, and SR-IOV technology. See Hardware Considerations for Implementing SR-IOV <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Hardware_Considerations_for_Implementing_SR-IOV/index.html> and Configuring a Hypervisor Host for PCI Passthrough <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Installation_Guide/appe-Configuring_a_Hypervisor_Host_for_PCI_Passthrough.html>.


2) In the Administration Portal, select a logical network and enable device passthrough on the vNIC profile. See Enabling Passthrough on a vNIC Profile <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/sect-Virtual_Network_Interface_Cards.html#Marking_vNIC_as_Passthrough>.


3) Edit SR-IOV virtual function details. See Editing the Virtual Function Configuration on a NIC <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/chap-Logical_Networks.html#Editing_VFs_on_NIC>.

 In this step, make sure you enter “number of VF” as 10!!!!!  each for ens3f4 and ens3f5!!!
Since there is a bond from 2 PFs(ens3f4 and ens3f5), on each of them enable 10 VFs. You just need to press the edit button(pencil) and enter the desired number of VFs per each PF(physical function). In your case i think it is 10 ??
Once VFs enabled, you will see them all appear just like regular NICs. Note that PFs has a yellow icons and VFs should have a blue icons, so once you enable VF/s, you will see the VFs a blue icon NICs. (Currently you have none).


4) There is NO need to assign the SR-IOV via 'Host devices'. Please assign the sr-iov network interface via the 'Network Interfaces' ONLY as per next step 5.

5) Create a new network interface on the desired virtual machine, and select the device passthrough-enabled vNIC profile . See Adding a New Network Interface <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Virtual_Machine_Management_Guide/sect-Network_Interfaces.html#Adding_a_Network_Interface>.

Once VM will run with a nic1(network interface, not host device!) as 'SRIOV-Profile' vNIC, 1 VF will disappear from the host and will be attached directly to the VM.
Comment 2 Yaniv Kaul 2017-07-12 17:28:13 EDT
Dup of bug 1469842 ?
Comment 4 Meni Yakove 2017-07-17 04:23:39 EDT
*** Bug 1469842 has been marked as a duplicate of this bug. ***
Comment 5 Meni Yakove 2017-07-17 04:31:19 EDT
https://access.redhat.com/articles/2335291 should be fixed
Comment 6 Lucy Bopf 2017-07-17 20:56:49 EDT
Objective: Fix the article as described, and include links for 3.6, 4.0, and 4.1.
Comment 8 Jason 2017-07-21 15:20:01 EDT
Hi Meni,

Cu advised:

Sorry about delay. I still feel that link https://access.redhat.com/articles/2335291 <https://access.redhat.com/articles/2335291> is not accurate.
Exact steps should be like this . And last you should provide the screen shots for each of the steps in deployment guide.


SRIOV configuration Steps:
 
 
1) Enable virtualization extension, IOMMU function, and SR-IOV technology. See Hardware Considerations for Implementing SR-IOV <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Hardware_Considerations_for_Implementing_SR-IOV/index.html> and Configuring a Hypervisor Host for PCI Passthrough <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Installation_Guide/appe-Configuring_a_Hypervisor_Host_for_PCI_Passthrough.html>. 
 
2) In the Administration Portal, select a logical network and enable device passthrough on the vNIC profile. See Enabling Passthrough on a vNIC Profile <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/sect-Virtual_Network_Interface_Cards.html#Marking_vNIC_as_Passthrough>.
  
3) Edit SR-IOV virtual function details. See Editing the Virtual Function Configuration on a NIC <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Administration_Guide/chap-Logical_Networks.html#Editing_VFs_on_NIC>.
 
4) There is NO need to assign the SR-IOV via 'Host devices’ at this moment. Please remove the host device and assign the sr-iov network interface via the 'Network Interfaces' ONLY as per next step 5.
 
5) Create a new network interface on the desired virtual machine, and select the device passthrough-enabled vNIC profile . See Adding a New Network Interface <https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Virtual_Machine_Management_Guide/sect-Network_Interfaces.html#Adding_a_Network_Interface>.
Comment 11 Lucy Bopf 2017-08-11 02:36:03 EDT
Assigning to Byron for review.

Byron, instructions are in comment 10.
Comment 12 Allan Voss 2017-08-31 09:06:04 EDT
It's also not explained if it's possible to select vFs from different pFs. Following the docs exactly results in all VMs having vFs from the same pF, even when trying to distribute them for redundancy.
Comment 13 puneet 2017-08-31 09:10:42 EDT
FYI, This is what i got from our rhev-tech team recently.
The way to do it is via 'Specific Networks' sub tab in the edit PF dialog.

For example:
- Create net1 and net2 wit 'passthrough' vNIC profile.
- Via setup networks enable VFs on each PF
- Via setup networks dialog edit PF1 and choose net1 as spesific network and edit PF2 with spesific network net2.
- Add nic1 to the VM with net1 profile and nic2 with net2 profile.

This way you ensure that the guest will have interfaces from VFs of different PFs.

(In reply to Allan Voss from comment #12)
> It's also not explained if it's possible to select vFs from different pFs.
> Following the docs exactly results in all VMs having vFs from the same pF,
> even when trying to distribute them for redundancy.
Comment 14 Michael Burman 2017-08-31 09:16:28 EDT
Puneet is right, this is the way to achieve the selection of VFs from different PFs.

Maybe this information can be added as well for the SR-IOV procedure.
Comment 15 Allan Voss 2017-09-04 16:36:58 EDT
This is becoming difficult because the customer isn't able to make two different logical networks that use the same VLAN tag. I was able to create 2 logical networks with the same VLAN tag in a test environment, but I wasn't able to attach them to any NICs because the test environmnt was not in an environment that supports VLANs.

Will this work when VLANs are in use?
Comment 16 Michael Burman 2017-09-05 01:38:40 EDT
(In reply to Allan Voss from comment #15)
> This is becoming difficult because the customer isn't able to make two
> different logical networks that use the same VLAN tag. I was able to create
> 2 logical networks with the same VLAN tag in a test environment, but I
> wasn't able to attach them to any NICs because the test environmnt was not
> in an environment that supports VLANs.
> 
> Will this work when VLANs are in use?

Allan Hi,
To whom the question is pointed? next time please set the need info flag on the person you would like to answer your question/s.

I'm not sure i understand the question or your problem with vlans and not sure this is the right place to discuss all this. 
SR-IOV + vlan are supported and working as expected. 
There should be no problem to attach vlan tagged networks to NICs(even if the host not configured with vlans)
Note that if using networks with the same vlan tag ID, you can't attach those networks to the same interface on the host, only on different NICs on the same host. 
For specific customer issues feel free to contact me personally via e-mail or chat and to raise your questions in the rhv-tech mailing list.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.