Bug 1472980 - qemu requires libxenctrl.so.4.8()(64bit) but nothing is providing that library
qemu requires libxenctrl.so.4.8()(64bit) but nothing is providing that library
Status: CLOSED DUPLICATE of bug 1472573
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-19 13:37 EDT by David Hill
Modified: 2017-07-19 16:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 16:01:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hill 2017-07-19 13:37:51 EDT
Description of problem:
Can't install libguestfs on rawhide

[root@otto ~]# yum install libguestfs
Last metadata expiration check: 0:46:31 ago on Wed 19 Jul 2017 12:50:15 PM EDT.
Error: 
 Problem: problem with installed package perl-interpreter-4:5.26.0-395.fc27.x86_64
  - package perl-interpreter-4:5.26.0-395.fc27.x86_64 requires libperl.so.5.26()(64bit), but none of the providers can be installed
  - cannot install both perl-libs-4:5.24.1-390.fc26.x86_64 and perl-libs-4:5.26.0-395.fc27.x86_64
  - package perl-Sys-Virt-3.2.0-1.fc26.x86_64 requires libperl.so.5.24()(64bit), but none of the providers can be installed
  - problem with installed package perl-Sys-Virt-3.5.0-1.fc27.x86_64
  - package perl-Sys-Virt-3.5.0-1.fc27.x86_64 requires libvirt.so.0(LIBVIRT_3.4.0)(64bit), but none of the providers can be installed
  - package libvirt-libs-3.5.0-2.fc27.x86_64 requires libxenlight.so.4.9()(64bit), but none of the providers can be installed
  - cannot install both xen-libs-4.8.1-2.fc26.x86_64 and xen-libs-4.9.0-1.fc27.x86_64
  - package libvirt-daemon-kvm-3.2.1-3.fc26.x86_64 requires libvirt-daemon = 3.2.1-3.fc26, but none of the providers can be installed
  - package libguestfs-1:1.37.17-2.fc27.x86_64 requires libvirt-daemon-kvm >= 0.10.2-3, but none of the providers can be installed
  - package libvirt-daemon-3.2.1-3.fc26.x86_64 requires libxenlight.so.4.8()(64bit), but none of the providers can be installed
  - package libvirt-daemon-kvm-3.5.0-2.fc27.x86_64 requires qemu-kvm, but none of the providers can be installed
  - package qemu-kvm-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-kvm-2:2.9.0-1.fc26.1.x86_64 requires qemu-system-x86 = 2:2.9.0-1.fc26.1, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc27.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc27, but none of the providers can be installed
  - package qemu-system-x86-2:2.9.0-1.fc26.1.x86_64 requires qemu-system-x86-core = 2:2.9.0-1.fc26.1, but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc27.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - package qemu-system-x86-core-2:2.9.0-1.fc26.1.x86_64 requires libxenctrl.so.4.8()(64bit), but none of the providers can be installed
  - cannot install the best candidate for the job
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstalable packages)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Hill 2017-07-19 13:45:33 EDT

*** This bug has been marked as a duplicate of bug 1471649 ***
Comment 2 Richard W.M. Jones 2017-07-19 16:01:44 EDT
I suspect you've got a slightly out of date mirror of Fedora Rawhide
because these should all be fixed in the current versions of
packages.

*** This bug has been marked as a duplicate of bug 1472573 ***

Note You need to log in before you can comment on or make changes to this bug.