Bug 1474246 - [3.6] Installer doesn't always use absolute path for excluders
[3.6] Installer doesn't always use absolute path for excluders
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.6.z
Assigned To: Jan Chaloupka
liujia
:
Depends On:
Blocks: 1474339 1474341
  Show dependency treegraph
 
Reported: 2017-07-24 04:27 EDT by Sergi Jimenez Romero
Modified: 2017-09-05 13:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the ansible_ssh_user didn't have /sbin in their path then the playbooks may have failed to execute the excluder scripts during installation and upgrade. The full path is now used avoiding this problem.
Story Points: ---
Clone Of:
: 1474339 1474341 (view as bug list)
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergi Jimenez Romero 2017-07-24 04:27:13 EDT
Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Always

Steps to Reproduce:
1. PATH doesn't include '/sbin'
2. run the installer
3. installer will fail here:
  https://github.com/openshift/openshift-ansible/blob/release-1.5/roles/openshift_excluder/tasks/exclude.yml#L8

Actual results:

Task "Enable docker excluder" fails as it doesn't use the excluder absolute path.

Expected results:

Use the absolute path for the excluder as in other tasks, e.g.:
https://github.com/openshift/openshift-ansible/blob/release-1.5/roles/openshift_excluder/tasks/exclude.yml#L4

Additional info:
Comment 9 Jan Chaloupka 2017-08-17 10:30:14 EDT
Upstream PR: https://github.com/openshift/openshift-ansible/pull/5117
Comment 10 Jan Chaloupka 2017-08-17 10:31:06 EDT
3.6 backport as well: https://github.com/openshift/openshift-ansible/pull/5115
Comment 14 liujia 2017-08-22 04:19:09 EDT
Have added cases ocp-15375 and ocp-15380 to cover this scenario.
Comment 16 liujia 2017-08-23 21:46:08 EDT
Version:
atomic-openshift-utils-3.6.173.0.7-2.git.0.340aa2c.el7.noarch

Steps:
1. Create a non-root user on the host.
2. Add cloud-user to sudo group and edit /etc/sudoers to change sudo's secure path(delete default /sbin and /usr/sbin):
Defaults    secure_path = /bin:/usr/bin
3. Run install playbook with user cloud-user.

Install succeed.
Comment 18 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.