Bug 1474341 - [3.4] Installer doesn't always use absolute path for excluders
[3.4] Installer doesn't always use absolute path for excluders
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.4.1
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.z
Assigned To: Jan Chaloupka
liujia
:
Depends On: 1474246
Blocks: 1474339
  Show dependency treegraph
 
Reported: 2017-07-24 08:26 EDT by Scott Dodson
Modified: 2017-09-05 13:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the ansible_ssh_user didn't have /sbin in their path then the playbooks may have failed to execute the excluder scripts during installation and upgrade. The full path is now used avoiding this problem.
Story Points: ---
Clone Of: 1474246
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Jan Chaloupka 2017-08-17 10:29:06 EDT
Upstream PR: https://github.com/openshift/openshift-ansible/pull/5116
Comment 3 liujia 2017-08-20 22:27:48 EDT
Bug can not be re-produced, still discussing with dev and reporter.
Comment 4 liujia 2017-08-21 06:40:08 EDT
Bug has been reproduced, but no puddle available, assign bug back.
Comment 5 Scott Dodson 2017-08-22 16:05:07 EDT
openshift-ansible-3.4.128-1 in the latest puddle
Comment 6 liujia 2017-08-22 23:21:14 EDT
Version:
atomic-openshift-utils-3.4.128-1.git.0.45b61cf.el7.noarch

Steps:
1. Create a non-root user on the host.
2. Add cloud-user to sudo group and edit /etc/sudoers to change sudo's secure path(delete default /sbin and /usr/sbin):
Defaults    secure_path = /bin:/usr/bin
3. Run install playbook with user cloud-user.

Install succeed.
Comment 8 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.