Bug 1474339 - [3.5] Installer doesn't always use absolute path for excluders
[3.5] Installer doesn't always use absolute path for excluders
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.5.z
Assigned To: Jan Chaloupka
liujia
:
Depends On: 1474246 1474341
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-24 08:26 EDT by Scott Dodson
Modified: 2017-09-05 13:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the ansible_ssh_user didn't have /sbin in their path then the playbooks may have failed to execute the excluder scripts during installation and upgrade. The full path is now used avoiding this problem.
Story Points: ---
Clone Of: 1474246
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 liujia 2017-08-20 22:28:01 EDT
Bug can not be re-produced, still discussing with dev and reporter.
Comment 4 liujia 2017-08-21 06:40:48 EDT
Bug has been reproduced, but no puddle available, assign bug back.
Comment 5 Scott Dodson 2017-08-22 16:02:45 EDT
New puddle built with openshift-ansible-3.5.118-1
Comment 6 liujia 2017-08-23 01:07:30 EDT
Version:
atomic-openshift-utils-3.5.118-1.git.0.cac343b.el7.noarch

Steps:
1. Create a non-root user on the host.
2. Add cloud-user to sudo group and edit /etc/sudoers to change sudo's secure path(delete default /sbin and /usr/sbin):
Defaults    secure_path = /bin:/usr/bin
3. Run install playbook with user cloud-user.

Install succeed.
Comment 8 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.