Bug 1475132 - Packaging Rust applications/libraries
Packaging Rust applications/libraries
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
ChangeAcceptedF27, SelfContainedChange
:
Depends On: 1463429 1468545
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-26 02:48 EDT by Jan Kurik
Modified: 2017-08-14 10:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 10:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2017-07-26 02:48:19 EDT
This is a tracking bug for Change: Packaging Rust applications/libraries
For more details, see: https://fedoraproject.org//wiki/Changes/Packaging_Rust_applications_and_libraries

Add required tools/instructions for packaging applications/libraries written in Rust. Rust is a systems programming language that runs blazingly fast, prevents segfaults, and guarantees thread safety.
Comment 1 Jan Kurik 2017-08-10 02:17:52 EDT
On 2017-Aug-01, we have reached the Fedora 27 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo for 2017-Aug-11 meeting.

Please set this bug to the MODIFIED state to indicate it is already in the testable state, or provide an update describing the current state of implementation for this Change.

Thank you,
Jan
Comment 2 Igor Gnatenko 2017-08-10 02:31:49 EDT
So, the status update:

* Development of required things -- DONE
* Packaging guidelines -- DONE (on yesterday's FPC meeting they were approved)
* Release Engineering supports rich deps -- WIP (https://pagure.io/releng/issue/6889)

Unfortunately, right now even we can make this change testable / complete, we are still not able to deliver this work in Fedora due to Release Engineering.
Comment 3 Jan Kurik 2017-08-14 10:20:07 EDT
Deferring. Please resubmit the Change proposal for review to Change wrangler once this is ready.

For more info check https://pagure.io/fesco/issue/1760#comment-457211

Note You need to log in before you can comment on or make changes to this bug.