Bug 1475177 - RFE: postgresql-upgrade-devel subpackage
RFE: postgresql-upgrade-devel subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
: 1499532 (view as bug list)
Depends On:
Blocks: 1055293
  Show dependency treegraph
 
Reported: 2017-07-26 03:24 EDT by Pavel Raiskup
Modified: 2017-12-15 02:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-15 02:15:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
postgis patch (5.81 KB, patch)
2017-07-26 03:24 EDT, Pavel Raiskup
no flags Details | Diff
postgresql patch (2.74 KB, patch)
2017-07-26 03:24 EDT, Pavel Raiskup
no flags Details | Diff

  None (edit)
Description Pavel Raiskup 2017-07-26 03:24:00 EDT
Created attachment 1304613 [details]
postgis patch

Some PostgreSQL extensions need to be built also against "older" postgresql
server for pg_upgrade to work.

Jozef Mlích started this initiative some time ago ... I'm attaching the
patches.
Comment 1 Pavel Raiskup 2017-07-26 03:24 EDT
Created attachment 1304615 [details]
postgresql patch
Comment 2 Jozef Mlich 2017-10-08 10:01:45 EDT
*** Bug 1499532 has been marked as a duplicate of this bug. ***
Comment 4 Honza Horak 2017-10-11 08:52:50 EDT
There is one hard-coded version 9.3 (line 138), otherwise lgtm.
Comment 5 Pavel Raiskup 2017-10-11 10:09:38 EDT
Honzo, can you elaborate?  I can not find that string.
Comment 6 Petr Kubat 2017-10-11 10:10:25 EDT
>Honzo, can you elaborate?  I can not find that string.

I think that is the leftover version string I have mentioned in the postgis BZ.

Note You need to log in before you can comment on or make changes to this bug.