Bug 1475681 - [RFE][Tracker] Add initial Kibana dashboard
[RFE][Tracker] Add initial Kibana dashboard
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-metrics
Classification: oVirt
Component: RFEs (Show other bugs)
1.0.5
Unspecified Unspecified
high Severity high
: ovirt-4.2.3
: 1.1.4.2
Assigned To: Shirly Radco
Lukas Svaty
: FutureFeature
Depends On:
Blocks: 1583158 oVirt-Metrics-and-Logs 1465012 1513026
  Show dependency treegraph
 
Reported: 2017-07-27 03:30 EDT by Shirly Radco
Modified: 2018-05-31 05:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: ovirt-engine-metrics-1.1.4.2-1.el7ev
Doc Type: Enhancement
Doc Text:
Feature: Example dashboards have been added. Reason: To help users learn hows to create their own dashboards faster, by examples. Result: A directory has been added to /etc/ovirt-engine-metrics/ with the example dashboards and visualizations. They need to be copied to the local machine where the user views Kibana and uploaded using the Kibana UI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-31 05:38:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+
pstehlik: testing_plan_complete-
ylavi: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 88162 master MERGED Add add-dashboards-examples role 2018-03-13 10:00 EDT
oVirt gerrit 90510 None None None 2018-04-24 04:30 EDT
oVirt gerrit 90550 None None None 2018-04-24 04:30 EDT
oVirt gerrit 90636 None None None 2018-04-25 07:14 EDT

  None (edit)
Description Shirly Radco 2017-07-27 03:30:41 EDT
Description of problem:
Create a kibana dashboard to show the general health of the oVirt environment.
Comment 1 Yaniv Lavi 2017-07-31 05:04:29 EDT
Do we have a way to push a dashboard into Kibana externally in the viaq setup?
Comment 2 Shirly Radco 2017-07-31 05:33:27 EDT
According to what Rich said it will be possible in OpenShift 3.6.
Comment 3 Lukas Svaty 2017-08-18 04:03:42 EDT
Hi these would be few of the dashboard queries it would be interesting to see.

- some efficient queries from DWH report based on timeline (what was status of - DC, storage, VMs, hosts at specific time)
- API response avarage/actual times graph
- trend graph of disk space per storage / per DC / per cluster (future expectation of 1 month)
- parsable engine and vdsm logs based on Correlation-ID to easy seach cause of problem
Comment 4 Yaniv Kaul 2018-01-11 08:34:20 EST
Is that realistic to get into 4.2.1?
Comment 6 Lukas Svaty 2018-04-19 09:33:13 EDT
Error while importing visualizations:

Error: Could not locate that index-pattern-field (id: ovirt.engine_fqdn.raw)
KbnError@https://kibana.example.com/bundles/commons.bundle.js?v=10229:57511:21
SavedObjectNotFound@https://kibana.example.com/bundles/commons.bundle.js?v=10229:57640:6
FieldAggParamFactory/FieldAggParam.prototype.deserialize@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:49376:16
AggConfigFactory/AggConfig.prototype.fillDefaults/<@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:53866:20
AggConfigFactory/AggConfig.prototype.fillDefaults@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:53844:8
AggConfig@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:53758:8
AggConfigs/<.initialSet<@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:54464:19
AggConfigs@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:54462:22
VisFactory/Vis.prototype.setState@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:48822:20
__WEBPACK_AMD_DEFINE_RESULT__</</SavedVis.prototype._updateVis@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:56374:8
__WEBPACK_AMD_DEFINE_RESULT__</</SavedVis.prototype._afterEsResp/<@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:56317:28
processQueue@https://kibana.example.com/bundles/commons.bundle.js?v=10229:42452:29
scheduleProcessQueue/<@https://kibana.example.com/bundles/commons.bundle.js?v=10229:42468:28
$RootScopeProvider/this.$get</Scope.prototype.$eval@https://kibana.example.com/bundles/commons.bundle.js?v=10229:43696:17
$RootScopeProvider/this.$get</Scope.prototype.$digest@https://kibana.example.com/bundles/commons.bundle.js?v=10229:43507:16
$RootScopeProvider/this.$get</Scope.prototype.$apply@https://kibana.example.com/bundles/commons.bundle.js?v=10229:43804:14
link/</reader.onload@https://kibana.example.com/bundles/kibana.bundle.js?v=10229:62025:14
Comment 7 Red Hat Bugzilla Rules Engine 2018-04-19 09:33:20 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Shirly Radco 2018-04-23 03:25:52 EDT
I added a step to the kibana dashboards import

https://github.com/sradco/ovirt-site/blob/aa2d653c543eb51571b22455ba1e497032971c7a/source/develop/release-management/features/metrics/metrics-store-installation.html.md

In order for field of type raw to be accessed, the index should be refreshed before loading the visualizations.
They are generated automatically when a sting fields are saved to the index.
Comment 9 Lukas Svaty 2018-04-24 02:56:43 EDT
Same result after the refresh of indices:


Saved Objects: Could not locate that index-pattern (id: project.ovirt-metrics-test-engine.d3a9f511-0508-11e8-9a49-001a4a013f0b.*)

Error: Could not locate that index-pattern (id: project.ovirt-metrics-test-engine.d3a9f511-0508-11e8-9a49-001a4a013f0b.*)
KbnError@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:57511:21
SavedObjectNotFound@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:57640:6
applyESResp@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/kibana.bundle.js?v=10229:45045:37
processQueue@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:42452:29
scheduleProcessQueue/<@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:42468:28
$RootScopeProvider/this.$get</Scope.prototype.$eval@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:43696:17
$RootScopeProvider/this.$get</Scope.prototype.$digest@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:43507:16
$RootScopeProvider/this.$get</Scope.prototype.$apply@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:43804:14
done@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:38253:37
completeRequest@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:38451:8
requestLoaded@https://kibana.tlv-metrics-store.eng.lab.tlv.redhat.com/bundles/commons.bundle.js?v=10229:38392:10
Comment 10 Yaniv Kaul 2018-04-24 06:21:48 EDT
Target milestone is 4.2.2?
Comment 11 Shirly Radco 2018-04-24 09:07:56 EDT
(In reply to Yaniv Kaul from comment #10)
> Target milestone is 4.2.2?

I see I moved it to 4.2.3 by mistake. Moved back to 4.2.3.
Comment 13 Red Hat Bugzilla Rules Engine 2018-04-27 04:09:20 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 15 Lukas Svaty 2018-05-03 08:49:02 EDT
Yes, all indices were refreshed.
Comment 16 Shirly Radco 2018-05-14 03:02:40 EDT
Please make sure that you wait a minute and make sure that collectd and fluentd are running on the host with the vms. If the data about vms is not collected it can't be used in the widgets/dashboards.
Comment 17 Lukas Svaty 2018-05-14 10:12:50 EDT
What if there are no hosts/no Vms in the engine?
Comment 18 Shirly Radco 2018-05-14 14:35:40 EDT
Kibana only works with existing fields in the indexes.
If the field is not in the index you will not be able to import the widgets using it and they will have an error in the dashboard for the specific missing widget.
Comment 19 Lukas Svaty 2018-05-16 10:45:53 EDT
tried with production engine, ~8 hosts, few hundreds of VMs

Error: Could not locate that index-pattern-field (id: ovirt.engine_fqdn.raw)

Please schedule a meeting with me and I can show you this issue, if you require some additional logs please let me know which ones.
Comment 20 Lukas Svaty 2018-05-30 04:48:25 EDT
Verified after consultation with DEV on BRQ production environment

Version: ovirt-engine-metrics-1.1.4.2-1.el7ev

Needed to rerun playbook at least with --scope-engine
Comment 21 Sandro Bonazzola 2018-05-31 05:38:15 EDT
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.