Bug 1476309 - When copying files larger than 64K to a samba share, gvfs fails to complete the copy and reports "Invalid argument"
When copying files larger than 64K to a samba share, gvfs fails to complete t...
Status: NEW
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
26
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-28 11:17 EDT by Vito
Modified: 2017-07-28 11:17 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 598620 None None None 2017-07-28 11:17 EDT

  None (edit)
Description Vito 2017-07-28 11:17:34 EDT
Description of problem:
Attempting to copy files larger than 64K from Fedora 26 to a Windows network share using Nautilus fails with "Invalid argument" error message. There is nothing in the debug messages to indicate a problem.

gio copy reports the same error:
$ gio copy large.data smb://server/data/temp
gio: file:///home/user/large.data: Invalid argument

Copying file smaller than 64K works however:
$ gio copy small.data smb://server/data/temp
$

Also, if one uses regular cp and copies a large file to a gvfs mounted share, operation works:
$ cp large.data '/run/user/1000/gvfs/smb-share:server=server,share=data/temp' 
$

This worked with the same server on the same hardware running Fedora 25. It got broken with the Fedora 26 upgrade. The same problem occurs on all Fedora 26 boxes so far. 


Note that this problem has exactly the same symptoms as the bug #598620:
https://bugzilla.redhat.com/show_bug.cgi?id=598620



Version-Release number of selected component (if applicable):
samba-client-libs-4.6.5-0.fc26.x86_64
samba-common-libs-4.6.5-0.fc26.x86_64
samba-common-4.6.5-0.fc26.noarch
samba-client-4.6.5-0.fc26.x86_64
libsmbclient-4.6.5-0.fc26.x86_64
nautilus-3.24.2.1-1.fc26.x86_64
gvfs-smb-1.32.1-2.fc26.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Open Windows network share using Nautilus by browsing to smb://server/share/directory
2. Copy file larger than 64K to this remote share directory
3. "Invalid argument" message box pops up

Actual results:
Pop up message box (error) that says "Invalid argument"

Expected results:
File should be copied


Additional info:
Exactly the same problem has been reported in Fedora 13 as bugs #598620 and #615332. It was also in Gnome bugzilla as bug #588391. This might be a regression?
https://bugzilla.redhat.com/show_bug.cgi?id=598620
https://bugzilla.redhat.com/show_bug.cgi?id=615332
https://bugzilla.gnome.org/show_bug.cgi?id=588391

Note You need to log in before you can comment on or make changes to this bug.