Bug 1481144 - Events are displayed in wrong order, latest on the bottom
Summary: Events are displayed in wrong order, latest on the bottom
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.5.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.6
: ---
Assignee: Alexander Wels
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1484043 1486135 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-14 08:28 UTC by Petr Matyáš
Modified: 2017-09-19 10:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A regression bug caused system events to be sorted chronologically, earliest events at the top. Fix: Events are now properly sorted, latest at the top.
Clone Of:
Environment:
Last Closed: 2017-09-19 10:01:31 UTC
oVirt Team: UX
Embargoed:
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
screenshot (83.97 KB, image/png)
2017-08-14 08:28 UTC, Petr Matyáš
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 81228 0 None None None 2017-09-01 18:37:02 UTC

Description Petr Matyáš 2017-08-14 08:28:10 UTC
Created attachment 1312994 [details]
screenshot

Description of problem:
Latest events are shown on the very bottom (should be the same as BZ1478334)

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.5.2-0.1.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. open events on the bottom of the page
2.
3.

Actual results:
you need to scroll down for the latest events

Expected results:
latest events should be on top

Additional info:

Comment 1 Greg Sheremeta 2017-08-28 13:31:51 UTC
*** Bug 1484043 has been marked as a duplicate of this bug. ***

Comment 2 Greg Sheremeta 2017-08-28 13:33:03 UTC
Looks the same as Bug 1478687, assigning to infra

Comment 4 Petr Matyáš 2017-08-28 14:14:13 UTC
(In reply to Greg Sheremeta from comment #2)
> Looks the same as Bug 1478687, assigning to infra

It is the same, this one is just for 4.1, not 4.2.

Comment 5 Greg Sheremeta 2017-08-30 13:52:48 UTC

*** This bug has been marked as a duplicate of bug 1486513 ***

Comment 6 samuel macko 2017-09-01 11:55:13 UTC
Duplicate is not relevant.

This bug is about wrong order of events but bug marked as duplicated is about refresh of events tab.

Comment 7 Greg Sheremeta 2017-09-01 11:58:34 UTC
It's the same problem. You just don't see the new events because of the incorrect sort.

Comment 8 Petr Matyáš 2017-09-01 12:02:16 UTC
Well to be fair, this bug is older than the duplicate, so the it can't be a duplicate since the bug marked as duplicate didn't exist at the time this was created.

Comment 9 Michael Burman 2017-09-01 13:44:44 UTC
BZ 1478687 and this report are the same issue(and it doesn't matter who is duplicated on who), in the bottom line it's the same bug.

Comment 10 Petr Matyáš 2017-09-01 14:42:17 UTC
Exactly, so lets close your bug, as mine has better description as is older. As you can see QA contact could make heads or tails from your description.

Comment 11 Greg Sheremeta 2017-09-06 14:30:25 UTC
*** Bug 1486135 has been marked as a duplicate of this bug. ***

Comment 12 Petr Matyáš 2017-09-08 10:05:39 UTC
Verified on ovirt-engine-4.1.6.2-0.1.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.