Bug 1483838 - backport "--no-hostonly-default-device" dracut option
Summary: backport "--no-hostonly-default-device" dracut option
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut   
(Show other bugs)
Version: 7.5
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: 1431974 1437029 1460652
TreeView+ depends on / blocked
 
Reported: 2017-08-22 05:55 UTC by Xunlei Pang
Modified: 2018-04-10 18:10 UTC (History)
10 users (show)

Fixed In Version: dracut-033-513.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 18:07:53 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0964 None None None 2018-04-10 18:10 UTC

Description Xunlei Pang 2017-08-22 05:55:52 UTC
Description of problem:
kexec-tools needs this feature to remove needless devices under kdump.

Two dracut upstream commits:
commit 37f2fe55d dracut.sh: introduce "--no-hostonly-default-device" argument
commit 5634a3115 rootfs-block/module-setup.sh: check root_devs in cmdline_rootfs()


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Xunlei Pang 2017-09-12 02:39:16 UTC
Hi Lukas, could you please backport the feature to rhel7.5? We have several bugs dependent on this one and the customers want them to be fixed quickly.

Comment 4 Lukáš Nykrýn 2017-09-12 08:53:34 UTC
Looks backportable.

Comment 8 Lukáš Nykrýn 2017-10-26 12:05:01 UTC
I had to kinda modify the second patch to match the rhel7 code.
https://github.com/lnykryn/dracut/commit/e2afcc958be19287bc23d9c0a052b5ac57bb3df3

Can you please try this scratch build:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14376384

Comment 9 Dave Young 2017-10-27 07:35:02 UTC
According to test, rhel7 still lacks below commit, but I'm not sure if it depends on other commits.

commit 07a081f352497258862ae164d11d9e6dc2c5b959
Author: Harald Hoyer <harald@redhat.com>
Date:   Fri Nov 13 13:40:38 2015 +0100

    dracut.sh: remove the concept of host_modalias
    
    We can never gather enough information about compiled in modules, so
    don't pretend to know and do smart decisions.


Maybe we can go with below changes, it passed my test, what's your opinion?

The changes is based on dracus.sh in your scratch build

--- dracut	2017-10-27 14:57:26.401855223 +0800
+++ dracut.new	2017-10-27 15:34:11.948891591 +0800
@@ -1121,8 +1121,9 @@ if [[ $hostonly ]] && [[ "$hostonly_defa
             [[ -b $_dev ]] && push host_devs "$_dev"
         done < /etc/fstab
     fi
+fi
 
-
+if [[ $hostonly ]] && [[ "$hostonly_default_device" != "no" ]]; then
     # record all host modaliases
     declare -A host_modalias
     find  /sys/devices/ -name uevent -print > "$initdir/.modalias"

Comment 10 Dave Young 2017-10-27 07:40:00 UTC
Oops, should be be below changes which works for me:

--- dracut	2017-10-27 14:57:26.401855223 +0800
+++ dracut.new	2017-10-27 15:38:43.638591013 +0800
@@ -1121,8 +1121,10 @@ if [[ $hostonly ]] && [[ "$hostonly_defa
             [[ -b $_dev ]] && push host_devs "$_dev"
         done < /etc/fstab
     fi
+fi
 
 
+if [[ $hostonly ]]; then
     # record all host modaliases
     declare -A host_modalias
     find  /sys/devices/ -name uevent -print > "$initdir/.modalias"

Comment 11 Lukáš Nykrýn 2017-10-27 12:35:41 UTC
Backporting the whole patch would not probably cause any regressions, but let's be careful and let's just go with your solution

Comment 17 Peter Kotvan 2017-12-11 10:13:28 UTC
Verified on with RHEL-7.5-20171130.0 dracut-033-520.el7.

Comment 20 errata-xmlrpc 2018-04-10 18:07:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0964


Note You need to log in before you can comment on or make changes to this bug.