Bug 1437029 - apply "--no-hostonly-default-device" in mkdumprd
Summary: apply "--no-hostonly-default-device" in mkdumprd
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dave Young
QA Contact: Qiao Zhao
URL:
Whiteboard:
Keywords:
Depends On: 1483838
Blocks: 1431974 1431982 1469549 1473055 1507354
TreeView+ depends on / blocked
 
Reported: 2017-03-29 10:36 UTC by Xunlei Pang
Modified: 2018-04-11 01:38 UTC (History)
3 users (show)

Fixed In Version: kexec-tools-2.0.15-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 14:08:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0807 None None None 2018-04-10 14:10 UTC

Description Xunlei Pang 2017-03-29 10:36:15 UTC
Description of problem:
We currently pass "--hostonly-cmdline" to dracut when making kdump initramfs,
this is useful to collect more information on the host, but on the other hand it also results in more needless stuff added to kdump.

For example, more host devices(like lvm devices, devices mounted to /boot, /boot/efi, etc) will be generated as "wait_for_dev", then kdump must wait for all the devices ready.

Actually, Fedora doesn't have "--hostonly-cmdline", it works all the time as well. There is some difference regarding dracut between RHEL7 and Fedora, we need to investigate and see if can keep align with Fedora.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Remove "--hostonly-cmdline" for RHEL7.5

Additional info:

Comment 2 Xunlei Pang 2017-09-06 01:35:54 UTC
After some discussion within team, we decided to keep "--hostonly-cmdline" and add the new "--no-hostonly-default-device" feature instead.

Comment 6 Dave Young 2017-11-01 08:25:39 UTC
*** Bug 1467567 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2018-04-10 14:08:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0807


Note You need to log in before you can comment on or make changes to this bug.