Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1431974 - Don't always mount the root file system of 1st kernel under kdump if not needed
Don't always mount the root file system of 1st kernel under kdump if not needed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.4
Unspecified Linux
unspecified Severity medium
: rc
: 7.5
Assigned To: Dave Young
Emma Wu
Jiri Hornicek
:
: 1467567 (view as bug list)
Depends On: 1437029 1483838
Blocks: 1420851 1469549 1431982 1473055 1507354
  Show dependency treegraph
 
Reported: 2017-03-14 04:20 EDT by Xunlei Pang
Modified: 2018-04-10 21:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.15-7.el7
Doc Type: Enhancement
Doc Text:
*kdump* allows a `vmcore` collection without the root file system being mounted In Red Hat Enterprise Linux 7.4, *kdump* required the root file system to be mounted although this is not always necessary for the collection of a `vmcore` image file. Consequently, *kdump* failed to collect a `vmcore` file if the root device could not be mounted when the dump target was not on the root file system, but, for example, on a usb or on the network. With this enhancement, if the root device is not required for dump, it is not mounted, and a `vmcore` file can be collected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 10:08:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0807 None None None 2018-04-10 10:10 EDT

  None (edit)
Description Xunlei Pang 2017-03-14 04:20:19 EDT
Description of problem:
Due to dracut history, root device is always mounted by kdump initramfs. Actually for the dump target not located at the root file system, e.g. usb kdumping, network dumping, etc, we do not need mount it to /sysroot under kdump.

This can save some memory, and avoid potential problems regarding root file system.

Version-Release number of selected component (if applicable):
any

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 6 Dave Young 2017-11-01 04:33:16 EDT
*** Bug 1467567 has been marked as a duplicate of this bug. ***
Comment 13 Jiri Hornicek 2018-03-22 06:36:42 EDT
Hi Dave,

I've changed the Doc Text. Can you have a look at it, please?

Thanks, 

Jura
Comment 14 Dave Young 2018-03-22 07:26:22 EDT
Hi,

See below comments, other than that it looks good, thanks!

>In Red Hat Enterprise Linux 7.4, *kdump* required the root file system to be mounted although this is not necessary for the collection of a `vmcore` image file.
  
  "it is not always necessary" is better because when dump target is root then root filesystem is still needed.

> Consequently, *kdump* failed to collect a `vmcore` file if the root device could not be mounted because the dump target was located externally,

 "when the dump target was not root file system" should be better.

> for example on a usb or on the network. With this enhancement, if the root device is not required for dump, it is not mounted, and a `vmcore` file can be collected.
Comment 15 Jiri Hornicek 2018-03-22 07:47:10 EDT
Hi Dave,

I changed the text and hope it's OK now. Thanks for a very quick response.

Jura
Comment 17 errata-xmlrpc 2018-04-10 10:08:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0807

Note You need to log in before you can comment on or make changes to this bug.