Bug 1493090 - dnf system-upgrade fails with assorted problems
Summary: dnf system-upgrade fails with assorted problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt-java-connector
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On: 1484585
Blocks: F27BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-09-19 11:11 UTC by Stephen Gallagher
Modified: 2017-09-20 15:36 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-20 15:36:49 UTC


Attachments (Terms of Use)

Description Stephen Gallagher 2017-09-19 11:11:38 UTC
Description of problem:
I have a fully-upgraded F26 x86_64 system. I cannot upgrade to Fedora 27 pre-Beta. DNF reports issues with the download (see below).


Version-Release number of selected component (if applicable):
dnf-2.6.3-11.fc26.noarch
dnf-conf-2.6.3-11.fc26.noarch
dnf-plugins-core-2.1.3-1.fc26.noarch
dnf-yum-2.6.3-11.fc26.noarch
libdnf-0.9.3-1.fc26.x86_64
python2-dnf-2.6.3-11.fc26.noarch
python3-dnf-2.6.3-11.fc26.noarch
python3-dnf-plugins-core-2.1.3-1.fc26.noarch
python3-dnf-plugins-extras-common-2.0.2-1.fc26.noarch
python3-dnf-plugin-system-upgrade-2.0.2-1.fc26.noarch


How reproducible:
Every time

Steps to Reproduce:
1. `dnf system-upgrade download --releasever=27`

Actual results:

Error: 
 Problem: package abrt-java-connector-1.1.0-8.fc24.x86_64 requires librpm.so.7()(64bit), but none of the providers can be installed
  - problem with installed package abrt-java-connector-1.1.0-11.fc26.x86_64
  - rpm-libs-4.13.0.1-7.fc26.x86_64 does not belong to a distupgrade repository
  - abrt-java-connector-1.1.0-11.fc26.x86_64 does not belong to a distupgrade repository

Expected results:
Packages are downloaded and I can run `dnf system-upgrade reboot` to perform the upgrade

Additional info:

Comment 1 Fedora Blocker Bugs Application 2017-09-19 11:12:45 UTC
Proposed as a Blocker for 27-beta by Fedora user sgallagh using the blocker tracking app because:

 "For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed." from Beta Criteria

Comment 2 Stephen Gallagher 2017-09-19 12:01:49 UTC
I'm +1 blocker on this. Apparently this should be fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2017-2a110b5a82 so we should get this BZ added to that errata.

Comment 3 Petr Schindler 2017-09-19 12:08:00 UTC
I'm also +1 blocker

Comment 4 Kamil Páral 2017-09-19 12:21:24 UTC
I can reproduce this. If we push https://bodhi.fedoraproject.org/updates/FEDORA-2017-2a110b5a82 stable, the problem should be gone.

+1 blocker per criterion, marking as accepted

Comment 5 Kamil Páral 2017-09-19 12:49:21 UTC
abrt-java-connector-1.1.0-13.fc27 fixes this

Comment 6 Kamil Páral 2017-09-20 12:15:21 UTC
*** Bug 1484585 has been marked as a duplicate of this bug. ***

Comment 7 Kamil Páral 2017-09-20 15:36:49 UTC
The update has been pushed stable.


Note You need to log in before you can comment on or make changes to this bug.