Bug 1487425 - Add documentation for new satellite-change-hostname utility
Summary: Add documentation for new satellite-change-hostname utility
Keywords:
Status: CLOSED DUPLICATE of bug 1451564
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs Server Administration Guide
Version: 6.2.12
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite-doc-list
QA Contact: satellite-doc-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-31 21:42 UTC by Mike McCune
Modified: 2017-08-31 23:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-31 23:19:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike McCune 2017-08-31 21:42:34 UTC
Document URL: 

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html/server_administration_guide/chap-red_hat_satellite-server_administration_guide-maintaining_a_red_hat_satellite_server

Section Number and Name: Chapter 6. Maintaining a Red Hat Satellite Server

Describe the issue: With the addition of the RFE here:

https://bugzilla.redhat.com/show_bug.cgi?id=924383

we need a new section in the Server Admin guide on how to change the hostname of the Satellite server. This new utility will be called 'satellite-change-hostname' and has fairly simple set of arguments:

# satellite-change-hostname --help
Usage: satellite-change-hostname HOSTNAME [OPTIONS]

Example:
 satellite-change-hostname foo.example.com -u admin -p changeme

Options
    -u, --username USERNAME          admin username (required)
    -p, --password PASSWORD          admin password (required)
    -g, --program PROGRAM            name of the program you are modifying (defaults to satellite)
    -S, --scenario SCENARIO          name of the scenario you are modifying (defaults to satellite)
    -d, --disable-system-checks      runs the installer with --disable-system-checks
    -y, --assumeyes                  Answer yes for all questions
    -h, --help                       help

Feel free to reach out to John Mitsch as he is the engineer responsible for this new command and feature.

Comment 1 Andrew Dahms 2017-08-31 23:19:48 UTC
Hi Mike,

Thank you for raising this bug.

We already have a tracker for this update, which has been assigned and is currently being worked on as BZ#1451564.

I'll close this one as a duplicate, and update that bug so that it is clear that the content needs to be included in the 6.2 z-stream docs.

Kind regards,

Andrew

*** This bug has been marked as a duplicate of bug 1451564 ***


Note You need to log in before you can comment on or make changes to this bug.